Auto Save not working

I modified a table using javascript and even though at top it states All Changes saved, but technically when I come back the changes have been lost.

Please provide more information:
i.) Do you use SeaTable Cloud or SeaTable self-hosted (if self-hosted, which version)?
ii.) Post the code (or the relevant part of it) here
iii.) Which browser do you use? (Have you tried a different browser?)

  1. SeaTable Developer Edition v2
const mainTable = 'hospitals & clinics';
const mainView = 'Default View';
const mainLinkCol = 'Handled By';

const secTable = 'divya crm';
const secView = 'Default View';

const rows = base.getRows(secTable, secView);
rows.forEach(row => {
  if (row.Mobile && row.Name) {
    const querySet = base.filter(mainTable, mainView, `Mobile = ${row.Mobile} and Name = "${row.Name}"`);
    let linkedRow = querySet.first();
    if (linkedRow) {
      linkedRow = base.getRowById(mainTable, linkedRow._id);
      base.modifyRow(mainTable, linkedRow, { 'Name': linkedRow.Name, 'Mobile': linkedRow.Mobile, 'Handled By': 'xyz' });

  1. Tried both on Chrome as well as Firefox

I can assure you that the code does modify the changes and the specific column reflects with the modifications but not getting saved, probably? Any possible way to debug or check what is going wrong

@Karlheinz Could you verify?

I can share a base or share credentials if you guys want to debug!

So you said when you “come back” the changes are not saved. Exactly how did you “come back”?

After executing the script, have you ever seen the rows being changed?

  1. Modified using the above script.
  2. Waited for All changes saved to show up.
  3. Confirmed if the rows have been modified.
  4. Reloaded to see if the changes are saved and it wasn’t

Found the cause, so when the column is of type single select then the modification is not getting saved. I have to convert the column type to text, run the script and then modify the type back to single select.

1 Like