Distorted images when changing the row height


I can’t tell if the following bug has been around for a while, or if it just came up with the current version.
When there are images in a column and the row height is changed to “triple” or “quad”, the images are stretched vertically. The change to “double” seems to work though:

I cannot reproduce the problem on SeaTable Cloud.

Row height single:

Row height double:

Row height quadruple:

Please try with a different browser. Or check the browser console.

Hello rdb!

Thank you very much for the answer and for trying to reproduce it. I have tried it in three different browsers (Firefox, Edge and Chrome). The result is always the same.


Please specify/provide:

  • SeaTable Cloud or SeaTable self-hosted
  • If self-hosted: which version
  • screenshot from browser console
  1. I use SeaTable Cloud.
  2. I have a suspicion, but I will experiment a bit more. I think that “SeaTable” is bad at handling screenshots pasted from the clipboard. I work with the screenshot programme “Snagit”. Even when I save a screenshot as a file using Snagit, SeaTable can’t handle the file properly.

Do you save the images in a column of type image or something else?

Yes, the column type is “Image”:


I don’t use snagit, but I just pasted an image from clipboard into the Add images dialog (see below).

The scaling worked just fine.

It may occurred when the column width is narrow and the row height is changed to “triple” or “quad”.

Hi ayy, welcome to the forum!

I think you are onto something! Thanks for sharing.

When the column is narrow (narrower than the correctly scaled width of the image) the image’s proportions get distorted.

@Michail Can you test if this solves your problem?

I also noticed the dependence on the column width. But with an image pasted from the clipboard, the images remain distorted - no matter how wide the column is. If I set a larger row height and a sufficient column width from the beginning, a screenshot is still inserted distorted. The behavior does not seem to depend on the screenshot program used.

If I save a screenshot as a file and then paste that file, the image is also inserted distorted. It only works as expected if I insert an image file that is not from a screenshot.

By the way, an inserted image file also gets distorted if the column gets too narrow. Shouldn’t the image file get smaller instead?

I’ll test that.

That depends on your objectives: Do you want to maintain proportions or do you want to display the image as large as possible (even at the expense of proper dimensions). The developers decided that the latter was more important and I concur.


As of today, I can’t even paste screenshots directly into an image column.
Otherwise everything is the same: Everything that has a screenshot as origin is not processed properly by SeaTable (Windows).


I am sorry, I cannot reproduce your problem. Did you use up your storage quota?

Can you please make a little video and post it here (i.e., an animated gif) or send the video to support@seatable.io

No, my storage quota is far from being reached.

From clipboard

Ok. Thanks. We’ll need to investigate. Since I cannot reproduce the problem, we’ll have to dig a bit deeper.

Can you please check if you encounter the problem in all your bases?

I only have two bases at the moment. But the problem seems to occur only in this one base - but in all tables.

The problem has only been there since today. And I did only one thing today in SeaTable: experiments with inserting pictures to find out why Seatable has the problems with inserting clipboard pictures.

Can you export the base (dtable format) and send it to support@seatable.io?

I am very sorry, but I cannot send you the base in question because it contains very sensitive data (addresses, passwords, etc.).

I have now restored a dtable file that is several days old from a backup. I found it very useful to be able to track any changes by means of “logs” (thanks for that!).

I have over 200 files in the recycle bin due to the frequent insertion and deletion of screenshots and other images. Could this possibly be the cause of the problem described? Unlike the workspace recycle bin, you can’t seem to delete a base’s recycle bin. Can you?

I’ll leave the broken base in the workspace for a while so that I can possibly help you find the error in another way.

The real problem, however, is still that Seatable can’t seem to handle screenshots or files that come from screenshots. This is a big problem for me!

You can manually delete files using “Attachments management”.

An autoremoval for unused attachments will be added soon.

As I said earlier: I cannot reproduce the problem. So I doubt it’s a general issue. You said yourself: The problem manifests only in one base.