Error when trying to update plugins

I recently upgraded to Seatable 3.0.16 EE, doing all the necessary extra steps in the documentation. However, today i went to update my plugins and this is what appeared:

When clicking on the button to upgrade, an error notification pops up.
Another error pops in External Apps (though i don’t use it):

I couldn’t find out what’s causing it from the logs, but perhaps you may be able to help me to fix this issue, here they are 2022-07-06 17:36:19,028 [ERROR] django.request:230 log_response Internal Server -


Hey typhon,
I checked your logs you send via pastbin. The only clear error message I would detect was the following:

MySQLdb._exceptions.OperationalError: (1054, "Unknown column 'dtable_external_apps.visit_times' in 'field list'")

If you have SQL errors like missing columns in the database then usually the update scripts were not executed. Did you probably forgot to execute the database update like described here?

Here is how the SQL-table in dtable-db should look like with version 3.0.16

mysql> describe dtable_external_apps;
| Field       | Type         | Null | Key | Default | Extra          |
| id          | int(11)      | NO   | PRI | NULL    | auto_increment |
| token       | varchar(36)  | NO   | UNI | NULL    |                |
| dtable_uuid | varchar(36)  | NO   | MUL | NULL    |                |
| app_type    | varchar(255) | NO   |     | NULL    |                |
| app_config  | longtext     | YES  |     | NULL    |                |
| created_at  | datetime(6)  | YES  | MUL | NULL    |                |
| visit_times | int(11)      | NO   |     | 0       |                |
| creator     | varchar(255) | YES  |     | NULL    |                |

Best regards

Hey, thanks for the help!

I was pretty sure i did the migration, but after running that describe command it seems that in fact the migration did not occur. However, as i tried running the commends again, i would either get no output (and no migration or some errors).

Is there any way to check the version of the current database?

I actually managed to successfully migrate and the output of the describe command is now looking like you said it should:
However, i still get the same issue with the plugins and external apps.

After looking at logs again after upgrading the database, i saw something about the plugin repo and checked the . Apparently i had second PLUGINS_REPO_ID varible with a different value that was messing things up - i deleted the new one which must have gotten there during this last 3.0 update when i added things to that config and plugins are working perfectly now.

So to summarize:

  • Upgrading the database properly fixed the external apps issue
  • A second PLUGINS_REPO_ID with a wrong value was causing the plugins to not be updatable

Again, thanks for the help with the database and help me unravel this particular mystery!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.