Images Broken when sharing via external link

We have a view with an image column. When we share with an external link to user that is not logged in the images break. Please advise!

Hey George,
did this happen on cloud.seatable.io or on a self-hosted system? If it is self-hosted, which version do you use?

Using cloud.seatable.io. I suspect you might be blocking permissions to .webp files. E.g. a jpg file is seems to shareable when a user is not logged in … but not the webp.

(I would send links as an example but the forum will not let me share links as I am a new user…)

We will check the issue.

Same issue. Really troublesome for us. Our images are jpg though.

Any ideas of a temporary workaround maybe?

EDIT: Not exactly sure how, but I seemed to have fixed it. In our case, images were coming in as a LookUp Field from a table which we had set Read Permission to Admin Only. Changing these permissions to everyone seems to have fixed it.

EDIT 2: Or maybe not. Just changed permission to Admins Only again and it keeps working. Maybe Seatable devs have fixed this on their side.

EDIT 3: This is even weirder. Same embed works on one page but then not in another page.

This sounds like a caching problem. Please clean the browser cache and try again.