"Internal Server Error" when opening base (enterprise docker version)

Hello support team,

I’m a newbie to Seatable, and I am evaluating it for potential implementation in my job environment, however I gut stuck installing the on-premise enterprise docker version. Installation is fine, and I can create a base, but as soon as I open it I get the message

“Internal Server Error”.

In dtable-server.log I see

[2022-01-24 23:51:32] [ERROR] http-service.js[134] - dtable_uuid: 09b5a745e4524ec29e98c85a6e76dfe2 - Dtable load failed 09b5a745e4524ec29e98c85a6e76dfe2

Any idea how to solve this? We are very impressed by Seatable and would really like to use it!

Best,

Simon

Hi Simon,
welcome to the SeaTable Forum!
You’ll need to give us a little more info for efficient debugging. How did you set up your system? HTTP or HTTPS - with Let’s Encrypt or your own SSL certificates?

Please make sure that the paths are correct in ccnet.conf and dtable_web_settings.py. (If you use http, the paths must begin with http://; if you use https, the paths must begin with https://)

You can also post your Compose file and your conf files here (after removing your passwords). Then we can have a look.

This is quite a typical problem if you use a custom domain other than “localhost”.
SeaTable stores the bases in the “dtable-server”, while the interface you see is the “dtable-web”. When you can see the interface, it means the dtable-web is fine, that the bases cannot be loaded is due to the fact that dtable-server cannot be accessed.

You need to change the domain name also for the dtable-server in the dtable_web_settings.py:

Details see the dtable_web_settings.py - SeaTable Admin Manual

Thanks a lot for the quick replies!

Currently I use http configuration (no https yet).

My dtable_web_settings.py looks like this:

IS_PRO_VERSION = True

DATABASES = {
    'default': {
        'ENGINE': 'django.db.backends.mysql',
        'HOST': 'db',
        'PORT': '3306',
        'USER': 'root',
        'PASSWORD': 'MYPASSWORD',
        'NAME': 'dtable_db',
        'OPTIONS': {
            'charset': 'utf8mb4',
        },
    }
}

CACHES = {
    'default': {
        'BACKEND': 'django_pylibmc.memcached.PyLibMCCache',
        'LOCATION': 'memcached',
    },
    'locmem': {
        'BACKEND': 'django.core.cache.backends.locmem.LocMemCache',
    },
}
COMPRESS_CACHE_BACKEND = 'locmem'

SECRET_KEY = 'MY_SECRET_KEY'

# for dtable-server
DTABLE_PRIVATE_KEY = 'MY_PRIVATE_KEY'
DTABLE_SERVER_URL = 'http://seatable.MY_DOMAIN.de/dtable-server/'
DTABLE_SOCKET_URL = 'http://seatable.MY_DOMAIN.de/'

# for dtable-web
DTABLE_WEB_SERVICE_URL = 'http://seatable.MY_DOMAIN.de/'

# for dtable-db
DTABLE_DB_URL = 'http://seatable.MY_DOMAIN.de/dtable-db/'

# for seaf-server
FILE_SERVER_ROOT = 'http://seatable.MY_DOMAIN.de/seafhttp/'

ENABLE_USER_TO_SET_NUMBER_SEPARATOR = True


PLUGINS_REPO_ID='99fe2bc0-6833-4e73-b7a0-d23079f3594c'

And my ccnet.conf like this:

[General]
SERVICE_URL = http://seatable.MY_DOMAIN.de/

[Database]
ENGINE = mysql
HOST = db
PORT = 3306
USER = root
PASSWD = MY_PASSWORD
DB = ccnet_db
CONNECTION_CHARSET = utf8

I tried to change all domain addresses (seafile.MY_DOMAIN.de) to 127.0.0.1 - but then I get an “Network error” message.

I’m grateful for any ideas for solutions or further analysis…

Thanks a lot!

Simon

The conf files look good.

Could you post the output of the browser console? This might shed a little more light on the root cause of the problem.

One more thing: Which version do you use? Please try with a 2.6 version. (We upgraded to Django 3.2 in version 2.7 and we had to realize that this caused unintended problem in http-only setups.)

Here we go:

Actually I do use 2.7.4 - I’ll now try with 2.6.

I would also be fine with using https, of course. Unfortunately using the standard setup for https I was unable to access both http and https (“Connection closed by host”), so I decided to start with the more simple http and care about https later.

Thanks a lot for your help!

Simon

One additional info: When I run “curl https://seatable.MYSERVER.de/dtables/06b5a745-e452-4ec2-9e98-c85a7e76dfe2?lang=de” (see above) I get an “{“error_msg”:“You don’t have permission to access.”}”. Does this help?

BTW: I run docker-compose within an Openstack Ubuntu Server 20.04 environment.

Do you encounter the same problem in SeaTable 2.6?

Is this your exact command ? Then the id of the base is wrong. In the screenshot, it is “09b5a”.

Have you tried creating another base? Same problem?

Hello everybody,

sorry for the silence. Finally I found out what the problem was! :slight_smile:

Stupid and simple: Our server is hosted in an OpenStack environment behind a firewall. I just had to add 127.0.0.1 to the “noProxy” value in ~/.docker/config.json.

Then everythink works fine.

Thanks a lot for your help!

Simon

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.