Issues with Creator column and admin and team Admin

Lots of bugs showing up:

  1. Added 5 team mates, their names show up in the creator colum, however, ***one tea member shows up as “anonymous”
    *** Tried renaming her from within team administration, everywhere her full name appears but she still shows as anonymous in the creator column. Tried giving her admin privileges to see if that changes anything, it didn’t.

  2. To test this out, I changed my name in the Personal settings to WET, and then in the team administration to WET World. To see which name would show in the creator column. Instead, soon as I change the name in the team administration the browser refreshes and gives me the error that I need to be an admin to access team administration. Turns out I am now no longer an admin! Didn’t touch the admin setting, only renamed.

The older team administration was really much better. This one is feels counter-intuitive and buggy. And the id feature is no longer available either. Can that one at least not be switched off until this one becomes error free? Before I was able to click on personal settings>team administration and it would take me to the older interface.

Thank you,

Signed in from the team members account and restored my admin access. I was still showing up as the owner of the base, but admin rights disappeared, upon just changing the name of this account and even though the team admin does not allow a user to remove their own admin rights.

Apologies for the inconvenience.

Deleted users are usually shown as “anonymous”. Is it possible that the records were created by a user that you then deleted?

Please add a modifier column and see if her name shows up correctly. (Once the value in the creator column has been set, it cannot be manually changed any more.)

This is a bug.

@CDB: Can you have a look.

We’ll add the option to set the ID soon.

… which is now a thing of the past.


We were getting the same result even with new entries. After signing in from her account and restoring my admin status, I tried renaming her again from the settings and just changing settings etc. Something did something and now new entries are showing up in her name, they weren’t before.

Thank you for the prompt response. Sorry if I sounded harsh or abrupt in my original post, was just freaking out a little at what happened.

We are a zero-cost purely volunteer run setup, giving scholarships to those from the developing world for certain healing short trainings. We were really struggling finding a solution for our data, and your offering has been a godsend! We are very grateful for what seatable allows us to do for our setup.

No worries. The bug you identified was a nasty one and should have been spotted during our tests. Apparently, we never tested with a team administrator and so the issue slipped through our fingers.

We are very pleased to hear that the system now works as it should and that it’s been very helpful for your work!

I took the liberty of marking the issue as solved. If you think this is premature, please follow up.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.