Library not found / does not exist

I’m looking for some guidance on fixing a broken install of SeaTable Developer Edition. Up until recently, everything worked but at some point, perhaps during an upgrade, something broke. Now if I click a base or create a new base, I get either Library does not exist. or Library 62c670b9-e851-4f1a-bd4b-5d7cd79b069e not found.

I can see all the data in the MYSQL database including 62c670b9-e851-4f1a-bd4b-5d7cd79b069e in workspaces > repo_id.

I re-read the extra upgrade steps and checked I’ve done everything. I also confirmed I ran all the sql upgrade statements.

Any advice or guidance on how to fix this or where to look in the logs for clues appreciated. Thanks.

Hey robflate,
what about new bases? Can you create new bases and does these work?
Here just some ideas to check:

  • Did you changed the new file_server of SeaTable?
  • Did you changed the permissions of the folder /opt/seatable/seatable-data/seatable/storage-data?
  • Did you deleted something below /opt/seatable/seatable-data/seatable/storage-data?


I cannot create new bases. I get the error;

Library 62c670b9-e851-4f1a-bd4b-5d7cd79b069e not found.

Did you changed the new file_server of SeaTable?

If you mean the Extra upgrade notice for v3.0 referring to dtable-storage-server.conf then yes I did.

Did you changed the permissions of the folder /opt/seatable/seatable-data/seatable/storage-data?

Not to my knowledge. The mapped folder on my Linux host system shows it as owned by root;

drwxr-xr-x 3 root root 4096 May 29 14:22 **storage-data**

If I docker exec into the container, it’s owned by root;

lrwxrwxrwx 1 root root 29 Sep 11 23:39 storage-data -> /shared/seatable/storage-data

I note that inside the container the path is not */opt/seatable/seatable-data/seatable/storage-data*. It is */opt/seatable/storage-data

Did you deleted something below /opt/seatable/seatable-data/seatable/storage-data?

Not to my knowledge. The mapped folder on my Linux host system contains a single empty folder and no files;

drwxr-xr-x .
drwxr-xr-x ./tmpfiles

I note that /opt/seatable/seafile-data contains lots of files and folders;

Hey robflate,
please check your if this library is mentioned in this file anywhere. e.g.

  • any other parameter

Best regards

It is not mentioned. Another string is mentioned in PLUGINS_REPO_ID;

  • Some info has been redacted with xxxxxxxx

Hey robflate,
I am sorry, but I have no idea what happened to your system. Can you add my private ssh key to the system and can I have a look by myself? Is that possible?

Thanks for the help! Yes I can add your SSH key.

Please add:

ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAACAQCkuvvsgf74vPtWJHqdndZei8BQ+e64qakRJGoAWpcrPCYe1wKq9Bz4NuJqO8kYZUUuTcYWfT6KKzhtv1j2u8lpM+4kIybqlzLZZOmrG4V8KTMTQeHKy1dz96wfcrT/oIDsRnizoA9zM7jevpO5gG3qviZ34wuKu3jr7dGjaxnoBhOQTutsIsHCeMZ4cDmA6PFqwxRP83DhMOqVSwyd/V4SjoBozLVD67tfq8+CalkXkIoF4k9iLF0hK6RH7jRRY8vv5SkNZv8ovTKSVlJ2q/1RCxdAeBPeQMX5l7E7NnvgLE+3bfq3DZeO0abwBTKfNo7Hs4pVkGSUeoLW6G0L1xSkksR4VPT6EIOxoEY/CT6mbk25kCHTy1JZE6TOZ1Dz7cUNsWwtz18xsj1yfnLGenMfv4b9Kyiaz1OmzBFqkWfyl3MsKje+OBxN+JZ0f74Pb/TJT9JXvUAMp4VT6VYpKN2tx/PuU953j7EQpOp+VRGylEvcPQz4/p0a3V0PjXCYdU5lLVf1c4IIZZritjuNbPKZEvvQ9lYaaMHM5PPm3OkENGurzozZxah8L0/JEPVFEnBNDyp7txKZx4QzqKL4lOWJHOr3AbU4cyB4v1XqAi8njJVfyIHBYfIVY+y+7uEvp6h+aJH/fWIu6Y7t77p7P1CBmUOyzdSipoLpVYywSjTg0w== christoph@seatable

I’ve sent you a message with the ssh details. Thanks.

Hey robflate,
I checked your system for 5 minutes and your setup is so far away from a “standard system”:

  • desktop system
  • shared system with multiple other docker vms
  • usage of “non-standard paths”
  • usage of non standard ports
  • variations in the docker-compose file
    • usage of traefik
    • additional security sttings
  • as soon as I login in SeaTable I get a cscf error.

Altogether, I cannot help you.
I can offer you to make a paid session to debug this problem together.

Thanks for taking a look.