Locking formula columns in EE

My employer uses SeaTable DE to manage our production schedule and it works fantastically! I’m currently evaluating the EE, mainly so we can lock down columns from accidental changes. Overall the permissions feature is great and definitely meets our needs, but I’ve noticed there isn’t an option to lock the formula of a formula column.

I’m the base admin/owner and can edit column permissions on all columns except for formulas and link formulas. For these the “edit column permissions” is greyed out. When I lock the table header, a non-admin account can still change the formula for both these columns, which is not ideal. However, they cannot edit any other column that has the edit options lock turn on. Is this a bug or intended design? Surely the permissions feature should allow locking of all column types?

In case it matters I have upgraded a copy of my live Seatable DE and deleted users down to 3 in order to test the EE version. Everything is working perfectly, so I don’t think this would be causing any issue but thought I’d mention it.

Maybe my question is too long…
Why is “Edit column permissions” greyed out for all formula and link formula columns in SeaTable EE? Other column types are not greyed out.


Column permissions was meant to control who can modify the cells. For formula and link formula columns, there is no need to control who can modify the cells. So it is greyed out.

In the next version 3.2, we will improve the behaviour. That column permissions can control the properties of the columns. And you can control who can modify the formula by the column permissions feature.

Thanks for replying Daniel. I’m glad to hear the feature will be improved in 3.2. Currently I can lock down all options for column types except formulas, so this does feel a little inconsistent.

I’m also surprised that the column description doesn’t get locked when locking the table header. Is there a reason for this? We’d prefer our users not to be able to edit this.

This will be fixed too.

Thanks @daniel.pan, that’s good to hear.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.