System admin via oauth?

I’m playing around with oauth and managed to get it working, however if I make one of the oauth users admin, I’m being asked for a password to enter systemadmin. But I have no password in seatable so how can I enter system admin?

I will check this behavior with the developers. Until then, can you please clean completely your browser cache and login again via oauth?

I have the same issue. I solved it via logout/login as @cdb said. Your auth will be valid for a while right after login. Other than that my user is the only one that has a local password. I removed all the other passwords from the database except for mine. I would need to access system settings with this password then.
This is the same behaviour as it is in Seafile.