Webhooks no longer working for me

My web app is heavily reliant on SeaTable webhooks. After fixing an infinite edit loop last night caused by a webhook-triggered table edit that then caused that same webhook to fire, my apps do not seem to receive any webhook POST requests from the SeaTable base anymore this morning. Before I continue debugging on my end, I wanted to verify that the webhook functionality is still up and running or that I haven’t managed to have my app IP/URL blocked from SeaTable in some way because of that edit loop?

Webhooks still don’t seem to be working. I tried this from first principles from a new base with the Zapier “Catch raw hook” Zap and table modifications do not result in requests on Zapier’s end. Am I missing something obvious or is the webhook functionality indeed down?

Hey Bram,
I can confirm that we have problems with the webhook of some bases. As soon as we solved this problem, I will update this post.
I am sorry for this.
Best regards,

1 Like

Hey Bram,
please try again. The webhooks should work again.
Best regards

Yes, they do! Thank you!

Unfortunately, the webhooks have stopped working again. Given that this happened after I tried to resolve another infinite webhook trigger loop, It’s more than likely that I’m causing this. I am happy to go over the steps I took right before the webhooks stopped working into more detail to help prevent this happening again.

Hey Bram,
thanks for the update. Can you please send a description of what you did to support@seatable.io.
Thanks and best regards

Thanks, I’ve sent the email.