2.0.6 Bad Gateway when opening Base - self-hosted

Hi everybody,

I hope that somebody can give me a hint how to fix my issue.
We installed seatable successfully last days (ubuntu 20.04, best practise installation with self created certificate). Website, Login, Administration works absolutely fine.
We are able to create Bases but if we want to open a base a “502 Bad Gateway” error is shown.

502 Bad Gateway

502 Bad Gateway


Hi, welcome to the SeaTable Forum.

Would you mind posting the content of your docker-compose.yml here? Remember to hide your passwords

Hi Karlheinz,

thanks for your fast answer.
Please find the content of the docker-compose.yml below.
Password is removed…

  - /opt/seatable/mysql-data:/var/lib/mysql  # Requested, specifies the path to MySQL data persistent store.
  - seatable-net

image: memcached:1.5.6
container_name: seatable-memcached
entrypoint: memcached -m 256
- seatable-net

image: redis:5.0.7
container_name: seatable-redis
- seatable-net

image: seatable/seatable-ee:latest
container_name: seatable
- “80:80”
- “443:443” # If https is enabled, cancel the comment.
- /opt/seatable/seatable-data:/shared # Requested, specifies the path to Seafile data persistent store.
- DB_HOST=db
- DB_ROOT_PASSWD= # Requested, the value should be root’s password of MySQL service.
- SEATABLE_SERVER_LETSENCRYPT=False # Default is False. Whether to use let’s encrypt certificate.
- SEATABLE_SERVER_HOSTNAME=cool.solutionit.de # Specifies your host name.
- TIME_ZONE=Etc/UTC # Optional, default is UTC. Should be uncomment and set to your local time zone.
- db
- memcached
- redis
- seatable-net


@daniel.pan would you please take a look what could be the cause here? Thanks!

Note!!! If you encounter “Network error” when loading a base

Use Chrome’s debug mode to check the detailed error. Normally, it is caused by wrong URLs in dtable_web_settings.py. As SeaTable server is composed of multiple components, it must read the correct URLs that users will use to access the service from settings. The configs will only be read from docker-compose.yml and write to the config file when you start SeaTable for the first time. If you modify the URLs in docker-compose.yml later, you must change them in dtable_web_settings.py manually.

The four URLs that used are below:

# The URL that users used to access a base
DTABLE_SERVER_URL = 'https://seatable.yourdomain.com/dtable-server/'
DTABLE_SOCKET_URL = 'https://seatable.yourdomain.com/'

# The URL that users used to access the service
DTABLE_WEB_SERVICE_URL = 'https://seatable.yourdomain.com/'

# The URL for the file server
FILE_SERVER_ROOT = 'https://seatable.yourdomain.com/seafhttp/'

Don’t forget to restart the service after modification:

docker exec -d seatable /shared/seatable/scripts/seatable.sh stop
docker exec -d seatable /shared/seatable/scripts/seatable.sh start

Thanks, I just realized this is part of the manual:
Developer Edition - SeaTable Admin Manual

I´m not allowed to post more than two links.
Last two URLs are changed as well.

Hey guys,

I restartet seatable after I´ve checked the config file, just to be sure.
Now it works …
No idea why. I didn´t change anything. During certificate installation and troubleshooting I´ve restartet several times.

Thanks for your hints. Finally it solved the issue.

Glad to hear that! So this could be marked as resolved.

4 posts were split to a new topic: 2.0.6 Bad Gateway when opening Base - self-hosted (2)


This is due to spam protection. If you post them in a code-fence / block, it’s fine (also better readable and makes it more clear it is a configuration setting).