2FA disabled for some users

I setup 2FA and want to force all user to use it. For this I enabled 2FA in the settings.

In the user settings I checked “Force Two-Factor Authentication” but this works only if the setting above is enabled. And this is the problem. For some users this setting is disabeld and I cannot enable it (see screenshot). Any ideas?


We use the Enterprise Version. I just create a new user and the same behavior: 2FA is disabled in the user settings. No chance to activate is.

If you want to enforce 2FA for all users, you must use this parameter in dtable_web_settings.py:

# Enforce 2-factor-authentication (2FA) for all users. Default is 'False'.
# Changing 'True' to 'False' will disable 2FA for all users (they can still enable it in their personal settings).

For more, see here: dtable_web_settings.py - SeaTable Admin Manual

Sorry - I have mixed up our subscription. We have Dedicated Cloud so we do not have access to dtable_web_settings.py.

I will contact support to change the setting.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.