After switching from http to https, access to the attached files disappeared

Good afternoon. After switching from http to https, access to the attached pdf (and others) files disappeared. The pictures open. New attached files are opened. Can you tell me if there is a script that can change links in files from http to https? Or how can this be fixed without a script?

Thank you!

in my lang.:
Добрый день. После перехода с http на https пропал доступ к прикреплённым файлам pdf. Картинки открываются. Новые прикреплённые файлы открываются. Подскажите есть ли скрипт который может поменять ссылки в файлах с http на https? Или как это можно исправить без скрипта?


Hello everyone again! :hugs: I still need help… I connected to mysql using HeidiSQL, but I didn’t find any links to the files. The most interesting thing is that files can be opened through attachment manager (I think because reverse proxy gets the link and changes it), but it doesn’t work that way inside the table… :smiling_face_with_tear:

If you help at least a little, I will be very grateful)

I leave a detailed description of my error to refine the system and better understand what happened…

I switched SeaTable to https, before that we worked in the http version for about a year. After transferring Seattable from http to https, access to the attached pdf files disappeared. The links in the cell with the files were attached in the http version, and have the form “http:// …” this is visible when I upload the table to excel.

Now, when I select a file from a cell, the system opens a new window with the main SeaTable page.

Hey eash,

I can confirm that right now the change of the URL of SeaTable-Server is not fully supported. Bases in general do not have a problem with a new URL, but files and pictures use the URL the moment they are created and the URL is not dynamic. This is the reason old files are not shown correctly.

We are working to fully support a change of the server-URL. Right now, there is only a workaround:

  • export your base
  • delete your base
  • reimport your base

Then all your attachments will show up again with the right URL.

1 Like

Unfortunately, your option didn’t work. It is not possible to export because the volume of the database is more than 100 MB.
However, I checked “export” → “delete” → “import” on a small database and the links remained the same.