Airtable migration - Key error on linked field

Hey there,

I’m regularly stepping by to retry my old plans to move from Airtable to Seatable. I’m really happy to see how Seatable improves over time. I think you’re doing a great job. Thank you for that.

I’ve just finished setting up my on premise installation including FAAS and python runner and thanks to the excellent documentation it all worked well from the get go. Good job there.

Now I’m facing an issue with my migration. The script is configured as good as I could do it but i’m getting this error.

error: Error: line 89, in <module> import_header() File "", line 82, in import_header convertor.convert_metadata() File "/usr/local/lib/python3.7/site-packages/seatable_api/", line 507, in convert_metadata self.convert_links(is_demo=True) File "/usr/local/lib/python3.7/site-packages/seatable_api/", line 588, in convert_links link_data = table[column_name]['data'] KeyError: 'bezieht sich auf'

In this case it’s a linked record that points back to the same table. Is this supposed to work? I double checked the spelling and the formatting is the same as other linked fields before which didn’t cause an error, so I suspect there’s an issues with links to the same table.

Here’s what it looks like in the migration script

links = [
    ('Bestellungen', 'bezieht sich auf', 'Bestellungen'),
    ('Goodies', 'Versand mit', 'Goodies'),

The lower one would again be one that links to records on the same table.

Thanks in advance for your help.


Hi Frank,

Thank you for your kind words, we are constantly working on improving SeaTable.

Have you already tried to run the script without the Link to other records column and then added it manually after a successful run?

No but is that supposed to work? I mean how would I keep track of the links without importing them? They would be lost, right?

EDIT: I did indeed run it now and those two are the ones causing the errors - with those lines commented the script seems to run fine but results seem to be broken still. For some reason even on import-headers data is imported and the links don’t seem to work yet. I’ll try running import-rows now to see how this develops.

Ok, i did try it and finished the migration for testing purposes. It seems without those two fields things work fine and after the import-rows step is done the imported data looks nice, except those two fields missing completely.

This is a bit of an issues as these “internal links” within the table are quite crucial for us. Is there a way to import them?

Apart from that formulas are still not imported and field types are often wrong but I think I remember this is because there is not way for you to retrieve this stuff over the API - it’s always been like that with Airtable I think.

nevermind, I found a way to get rid of those fields and ignore them for the import - so that’s not a factor for me anymore.

Will the two columns “Orders” and “Goodies” now not be transferred at all?
My thought was, if these columns are transferred, that you create a new column Link to other records and copy the values of the column to create the link again.

And you are right, not all column types are transferred correctly. We point out this issue in our help article.
Please adjust the column types after transferring the test rows to avoid the issue.