Airtable migration

Hi guys,

I have been trying to migrate data from Airtable to SeaTable. A couple of months ago I did so successfully with this script: Migration from Airtable Bases to SeaTable - SeaTable
However it does not seem to work anymore as I get this error message:

In the meantime Airtable went from API keys to personal Access Tokens so I suspect that that might be the reason the script is not working anymore.
Does anyone know another way to migrate the data? Or is there a way to fix the script? Exporting a CSV and importing has not worked unfortunately.

Thanks for the help!

We will check the issue when we have time.

I can not confirm, that the script does not work any more. I created at Airtable a personal access token with the scope data.records:read and it was possible for me to migrate the base to SeaTable.

Might it be that you try to use the old API key of Airtable? These are deprecated and does not work anymore.


I have tried that, but it did not work. To be precise: I have put the new personal Access Token here in the code where the API key used to be. Was that correct? Do I need to change anything else about the script? (Unfortunately I am not a developer :sweat: )

You replace the api key with the personal access token. That is correct.
Besides that, the error message is quite clear: the script has problems with the authentication - either against airtable or seatable. Please double check your input variables and try again.

If it does not work, I would create new keys and try again.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.