Apache2 proxypass

Hello,
my whole intranet is handling my services throuch apache2 with certbot for certificates.
I’ve installed seatable (dev edition) on a virtual machine(192.168.10.81) with ubuntu and docker.
the only parameter that I’ve changed in the docker-compose (except passwords!) is the domain name.
It’s now seatable.mydomain.com
I’ve pointed the registry to my external ip and forwarded ports 80 and 443 to my apache server.

I’ve created a vhost file named seatable.conf shared here : https://pastebin.com/z9MCz2fd

Everything works perfectly with http
When I use certbot, I can create the certificate and force the redirection to https
https://seatable.mydomain.com works perfectly and I can log.
However, when i try to open a database, I’m stuck at the rotating circle.
Using chrome tools, I can see a mixed-content alert.
If i allow mixed content, I get a CORS error.

What shall I do to get a working https ?

Why on earth would you use apache as a reverse proxy?

I’ve got a dozen of services, vm, container. All are currently handled by a apache server.
Setting a proxy pass to the nginx on seatable’s vm was a 2min work.
Why would I change that?

You can use a global nginx instance as a reverse proxy instead of apache.

Sorry, can’t help you with apache because I haven’t used it for years. It’s old, heavy, resource intensive

I have exactly the same issue, but i use nginx

Initially, I noticed on the stables application when trying to open the table in the browser (network track), requests were shown as mixed content warning and nothing was opened over https protocol.

But if you disable https redirection in the panel, then everything worked. So via http.

A similar problem is now with the n8n application

Here is the test deployed n8n app If you click execute workflow, it will be executed without errors via http.

But over https any actions hang and do not give the result. (I am 99% sure that content warning is similar to the previous application)

Take a look : (Maybe this behavior ngix will tell you something)

I accidentally noticed this anomaly: Loom recorded a video.

I comment: in the application, as a standard, I press execute a cube (get request, for example) while the https protocol is enabled - it hangs up as always.

But!! , if at this moment you update the nginx settings (if you press save & update in the console, then the caprover reloads this instance and nginx settings), then the REQUEST WILL BE FULFILLED!)

Then, of course, 10-15 seconds error 502, the container is loaded. And again you can refresh the page and it won’t work when you push it.

Maybe you have any suggestions what this might be related to?

Same issue i still have with seatables, just was easier to illustrate the strange behavior with n8n.