Automation with button: No PDFs attached to email

I have set up a button which first creates 2 PDFs then attaches them to an email and sends the email. However, the emails received have no attachments.
My assumption is that the email is sent before the PDFs are created. It takes a few seconds for the PDFs to appear in the column. What do you think?
I have done a test of another button that sends previously created PDFs and this works (attachments sent and received).

This issue report ties to this one of yours: Internal server error attempting to create 2 PDFs with 1 button click

Your assumption is correct:

The issue will be solved in the next release in some weeks from now.

is it considered as fixed in the latest release ?
I’m running 3.4 and I had the same kind of behaviour with these steps on one button :

  1. PDF creation
  2. Email including the PDF
  3. Change status of one field

When I clicked, I got a red cross on the button, meaning an error.
The status got changed, then the PDF appeared, but the email was not sent.

My guess is that the email can’t be sent as the PDF is still under creation.
How to solve that ?

Please upgrade to SeaTable 3.5.

@webdienste Can you retest and mark the topic as solved when it works for you?

Hi rdb,

I can confirm that it works. I will mark this topic as solved.

1 Like

Works indeed with latest

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.