Can not create an admin user on Ubuntu 20.04

Hello SeaTable Team,
When I created an admin user with the command docker exec -it seatable /shared/seatable/scripts/ superuser, the following error occurred:

Traceback (most recent call last):
  File "/opt/seatable/seatable-server-latest/seafile/lib/python3/site-packages/pysearpc/", line 85, in _get_transport
    transport = self._pool.get(False)
  File "/usr/lib/python3.7/", line 167, in get
    raise Empty

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "", line 10, in <module>
  File "/opt/seatable/seatable-server-latest/dtable-web/thirdpart/django/core/management/", line 419, in execute_from_command_line
  File "/opt/seatable/seatable-server-latest/dtable-web/thirdpart/django/core/management/", line 413, in execute
  File "/opt/seatable/seatable-server-latest/dtable-web/thirdpart/django/core/management/", line 354, in run_from_argv
    self.execute(*args, **cmd_options)
  File "/opt/seatable/seatable-server-latest/dtable-web/thirdpart/django/core/management/", line 398, in execute
    output = self.handle(*args, **options)
  File "/opt/seatable/seatable-server-2.7.9/dtable-web/seahub/base/management/commands/", line 88, in handle
  File "/opt/seatable/seatable-server-2.7.9/dtable-web/seahub/base/", line 181, in get
    emailuser = ccnet_threaded_rpc.get_emailuser(email)
  File "/opt/seatable/seatable-server-latest/seafile/lib/python3/site-packages/pysearpc/", line 125, in newfunc
    ret_str = self.call_remote_func_sync(fcall_str)
  File "/opt/seatable/seatable-server-latest/seafile/lib/python3/site-packages/pysearpc/", line 97, in call_remote_func_sync
    transport = self._get_transport()
  File "/opt/seatable/seatable-server-latest/seafile/lib/python3/site-packages/pysearpc/", line 87, in _get_transport
    transport = self._create_transport()
  File "/opt/seatable/seatable-server-latest/seafile/lib/python3/site-packages/pysearpc/", line 80, in _create_transport
  File "/opt/seatable/seatable-server-latest/seafile/lib/python3/site-packages/pysearpc/", line 44, in connect
FileNotFoundError: [Errno 2] No such file or directory

I also tried to execute the command in the seatable container, I received the same error:

I printed the socket_path in in file /opt/seatable/seatable-server-latest/seafile/lib/python3/site-packages/pysearpc/ with the result /opt/seatable/seafile-data/seafile.sock. But this seafile.sock does not exist:

My docker-compose file looks like (I have an example external network custom-volume to connect with seatable python runner and seatable python faas scheduler):

version: "3.8"

    image: our-company/seatable-mariadb:release-0.7
    container_name: seatable-mysql
    command: --max_allowed_packet=256M
      # "PASSWORD" is the password. Requested, set the root's password of MySQL service.
      - MYSQL_LOG_CONSOLE=true
      # Requested, specifies the path to MySQL data persistent store.
      - seatable-db:/var/lib/mysql
      - seatable-net

    image: memcached:1.5.6
    container_name: seatable-memcached
    entrypoint: memcached -m 256
      - seatable-net

    image: redis:5.0.7
    container_name: seatable-redis
      - seatable-net

    image: seatable/seatable-enterprise:2.7.9
    container_name: seatable
      - "80:80"
      - "443:443"
      # Requested, specifies the path to Seafile data persistent store.
      - seatable-shared-data:/shared
      - DB_HOST=db
      # Requested, the value shuold be root's password of MySQL service.
      # Default is False. Whether to use let's encrypt certificate.
      # Specifies your host name.
      # Optional, default is UTC. Should be uncomment and set to your local time zone.
      - TIME_ZONE=Etc/UTC
      - db
      - memcached
      - redis
      - seatable-net
      - custom-volume
    name: custom-volume
    external: true

  seatable-db: {}
  seatable-shared-data: {}

According to this post I created an user in the ccnet_db.EmailUser but after login the “Page unavailable” error appeared:

Could anyone tell me why this happens and how can I fix the problem?
Thank you very much in advance.

Best regards,

Did you start the server?

1 Like

Yes, I copied the license file into the seatable container and started the server before I created an admin user

The SeaTable interface looks good but I can’t login without an account.

I don’t know that error. But why do you run such an old version of seatable?

This version is running on our server. I tried to start the seatable locally.
Recently I restarted our seatable with docker-compose down and then docker-compose up -d. Now SeaTable is unavailable:

Page unavailable

Sorry, but the requested page is unavailable due to a server hiccup.

Our engineers have been notified, so check back later.

Could you help us please?

I don’t change the seatable version but I run the docker-compose pull. I don’t know if there is any changes of seatable/seatable-enterprise:2.7.9 from seatable since the last time I used

I absolutely don’t know in wich case the exception will throw an “Connection refused” error. Maybe someone of the team can give you better support than me.

Thank you very much for your help. Could you please inform someone in your team who knows this problem? :slight_smile:

Sorry, I coudn’t provide better help.
Unfortunately, I don’t have direct contact but they are reading the posts in this forum.

No problem, thank you for your quick response :slight_smile: I hope that we can fix this problem soon, because SeaTable on our server is down now and it is so important for us.

I am happy to help, but I fail to understand what the current problem is. I see multiple screenshots with different outputs. Is it “file is not found” or “connection refused”?

If you are a license holder of a paid SeaTable Server license, you can contact If you have a free 3-user license, it is possible that your license is fully used and hence you cannot create new users.

Thank you @AkDk7 @rdb very much for the quick support!
We figured out that our license expired and we updated the license. The problem is solved then. This information we just received when I tried out a new SeaTable version. Unfortunately this is not showed when I restarted the seatable server with seatable/seatable-enterprise:2.7.9, the status was “SeaTable started”.

1 Like

I take the liberty of removing the “Bug” tag from your description.

Sure, just go ahead :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.