Copy table to another base

Hi there.

I am developing a new table in a base. During the development process I don’t want this table to be visible to the other users in the base.
As far as I know I can’t make a table hidden for the other users. Is that correct?

Ofcourse I can create a new base and start developing the table there, but when finished developing the new table it should be placed in the other base. Is there an option to copy a table to another base?

I looked at exporting/importing, that doesn’t do the trick. I can only export in Excel format and import in CSV format. This means converting the file. And more important, I lose all column properties/settings/formulas.

Can you help?

Thanks !


Hi Peter,

First of all, I am very excited to see you really getting familiar with SeaTable!

You’ve been bringing up a lot of good points these days. For the most part, we had to tell you to keep patient. Now I have some good news: This problem, we can solve!

Have you taken a look at the custom permissions introduced with the most recent release update? You find more info in the release note.

Specifically, this is what you have to do: First, you define a custom sharing permission which only grants ro/rw permissions to the table(s) that you want to share. If this is not fine-grained enough for you, you can even define the access rights on a view level. Then, you use this very custom permission to grant the user access to the base. You’ll see: The user can only access the table(s)/view(s) that were included in your custom permission.

Pretty cool, eh?!

If this answered your problem, could you mark this question as solved. You do this by means of the icons at the bottom of every post.

Hi Ralph,

thank you for your quick reply!
You answer brings me to a question I had on my todo list. Asking about users and permissions.
I think your answer and the question on my list are connected. Or maybe not, wel’ll see.
In the last few days I already read the article you mentioned, couldn’t figure it out and let is rest for a while. But now it is actual again.

The custom permissions option isn’t visible in my configuration.
Schermafbeelding 2020-12-20 om 23.09.32

Why is that?

I was looking into this myself, and thought is has anything to do with the way I invited my users? Because in the Administration area I don’t see the invited users. In the Share Base option I can see the invited users (but can’t use the seach field. In the search field I only find myself, never any of the users mentioned below.) So the way users work isn’t very clear to me.

Again a long answer, sorry for that :wink:


Hi Peter,
I forgot mentioning one little bit and that caused confusion on your end.
In the current version, the custom permissions are only available via the share icon in the base (see below)

Additionally, we removed the menu item “custom permission” from the left menu and integrated it into the dropdown in the permission field (see below). (The position in the left menu was awkward because it was out of kind wit the other menu items.)

In the next version, schedule for release before the end of the year, we’ll integrate the custom icons in the share menu in the bases library as well.

Right, that helped. I hadn’t noticed the Custim Permissions over there.
I tested it right away, but still not clear.

I created the custom permission, but I can’t assign it to my existing (invited) users. As mentioned above, I can’t search for users, so it looks like I can’t assign these rights.

Below you see I have u user Mariska, but typing a M won’t match

And below you see the custom permission, but don’t know how to assign it. In this screen I can only assign the custom property to myself. Which is a bad idea as I am the owner.

And last, when inviting a new user, I can’t select the custom permission.

Must be doing something wrong…

Some new observations regarding my previous post.
There is different behaviour in setting permissions, depending on how to enter the sharing functionality.

When I enter via your Workspace management (where you see all your bases), and use the share option of your base there, I can modify the permissions of existing users. See screenshot below, I can click on the pencil and edit permissions and assign custom permissions. (which I want, so great!).

But… when I have my base open, using my table and then clicking on the share button on the right top screen, the permissions screen opens. But here I don’t have the pencil option to edit the permissions!

This explains why I couldn’t set the custom permissions! When entering the right way, I can set the custom permissions and hide the development table I want (my original question).

Leaves me with one question. What is the relation between entering users via the Administration screen and inviting via a link? Only the users added via the Administration are searchable in the permissions screen. The invited link users are displayed there, but aren’t selectable in the search screen. This means when deleting a user in the share screen, I can’t add the user again which is possible with users added via the administration screen.

Okay, two questions :slight_smile: It looks like I can’t use the “Invite Link” option to invite someone with cutsom permissions. This option isn’t presented. I can only invite with RO or RW link.

Hey Peter,

As I was looking at my own custom share permission dialog I see this

In this base called “pt” I have three tables: Projects, Tasks, and Clients. Under the first two tables, I also have multiple views.

For each view, and each table, I can decide if they can be seen, or can be edited. If I don’t select “Read Write” or “Read only”, just leaving it blank, this view, or this table, will be not visible. Then, I can save this combination as a permission, for example, “managers”.

Then, for each user who has permission to this base, I can decide which combination they enjoy.

You are right - the sharing permission settings in the workspace and in the base editor are currently not unified in the SeaTable Version 1.5. This will be fixed in 1.6, which will come out around Christmas.

Enjoy your holiday! It will be a better place after the new year celebrations!

1 Like