Ctrl-F find has different behaviour using second time


First of all, I very much like Seatable! I introduced it recently in one of my teams and we all love using it.

A frequently used shortcut is the Ctrl-F key to do a quick search throughout the table. But using it a second time gives an unwanted behaviour.

The situation:
I type CTRL-F, a seach field become visible and I can directly type my search text. I don’t have to enter/select the search-field to type my search text. The files are getting highlighted where the text is found. So far so good, behaviour like any other application.
But here’s the thing: after my first search I want to enter a second search, so I hit CTRL-F again and type my search-text. But this time after the CTRL-F the search-field doesn’t get selected and my search-text is typed into a record in by table, erasing the previous content! I lookt like I have to select the search field first, clear the previous search-text and fill in my new search-text.
I have deleted many times the content of some fields because of this.

As a reference, in other applications like Word, Excel etc you can use CTRL-F the same manner every time. Hit CTRL-F and directly type in the search-text. Second time exactly the same.

Easy to reproduce…

To my experience this is a bug and it would be very helpful, and preventing many errors at all collaborators, if this could me fixed.

Thanks !


Hi Peter, thanks for letting us know about your experience with the search function. Glad to hear that you and your team are enjoying SeaTable!

Indeed, for the non-modal search field, pressing Ctrl+F should reset the search result so that you can start a new search. Before we can improve this for you, allow me to offer you an alternative solution:

Press ESC between old and new searches:

  1. Press Ctrl+F and start typing your search criteria.
  2. Press ESC to escape the current search, and then press Ctrl+F again to start a new search.

Hope this helps a little! (However, this only helps if you don’t click on any cell after a search…)
I have informed the developing team.


Hi Karlheinz,
thank you for your quick reply. I hope you can improve the search for me, CTRL-F should indeed clear the search field and have focus.

Regarding the alternative solution: your suggestion only works when only doing a search and never leave the search field. In my case I search for some text, which is often in a long text field. So I have to double click on the long field to see the whole content. I close the long file window and want to do a new search. Using ESC won’t help in those cases. Using CTRL-F and typing the search text will overwrite my long text field, and hoping I notice that so I can do a CTRL-Z to restore the content.

Hope you understand the problem, and I am hoping on a solution in one of the next releases (like you guys have nothing else to do :wink:)


In Excel, when you type CTRL-F when search dialog is not focused, the search dialog will get focus and the cursor will be at the end of existing text.

We will implement such a behaviour.

:wink: normally we have a lot to do, but user satisfactory is our first priority! Like Daniel said, the search behavior will be improved, let’s wait and see how it works for you by then!

“In Excel, when you type CTRL-F when search dialog is not focused, the search dialog will get focus and the cursor will be at the end of existing text”
And to be precise: the existing search is selected, making instant typing of the new search text possible. The cursor will be at the end of the selected text in Excel. Imporant detail, because therefor you can type your search text without having te delete the previous search text.

We will do in the same way.

We have worked on the Search function for the new release. Can you please test it? If it works as expected, please mark this solved.

Works like a charm! Thanks!

Excellent! :ok_hand:t2: