Deduplication Plugin: Removes records, followed by server disconnect 502 Bad Gateway, shortly after all records are back

Hi all,

I’m experiencing a strange issue with the deduplication plugin. Using a pre-defined view and 4 columns (3 Text and one Date) I identified around 800 duplicates. When removing the duplicates using the plugin everything seems fine at first - the record count is updated, I can browse around in the base, or in other areas of Seatable until shortly after I see the spinner/loading icon and takes a while until I see a 502 Bad Gateway message on screen.
Again after a short while the page is back with all records, that were previously removed…
Tried at least 5 times and I can reproduce it. Base UUID is 70615648-7657-4455-9763-31d121e2b007 on cloud.
Am I running into any limits? Is something broken in my base?

Things I double checked:

  • Made sure I don’t have a second seatable tab open
  • tried a new tab / window
  • tried multiple times
  • tried to get more insights about the actual error in dev console / websocket messages. No luck
  • tried if it makes a difference if the Default View or my custom view are open before I start the deduplication plugin