Excel Export shows technical IDs istead of values

when exporting our Base, we stumble over technical IDs that we would expect to be replaced by textual values. Here is a small, reproducible example:
there are two tables: a table of Users and a table of (e.g. Social-Media-)Posts. When grouping Posts by Name the Excel Export exposes technical IDs of the Names in the Users table (see the red lines):

Note the following important details:

  • In the Users table the Names are chosen from a drop down (and the exposed technical IDs are in fact the IDs of these drop-down options, as I checked from the API)
  • The Names in the Posts table are linked from the Users table

Am I doing anything wrong, or is this, as I think, a bug in the export functionality?


I tried to reproduce your problem. I exported one of my tables. This is what I got:

There is NO general problem when exporting tables that are grouped by single select values.
(The continent and country columns are single select columns, the column industry is a link column.)

In your case, where the single select values are pulled from another table, the export file indeed merely contains the options’ IDs (as opposed to the options’ values).

From my point of view, this is not a bug. The values are correct. But it’s not the information you wish to see.

We will improve the export in the future.

I’m still not sure I agree with exposing SeaTable’s machinery to users. And I still don’t agree that you did reproduce my case. In my case, country would be a linked column which is a single select column in the source table. This does not seam to be the case here.

An alternative would be to make Industry a single select column in the source table and group by Industry.

Yes, I did. As I said:

This is exactly what I did for testing purposes:

I can only reiterate what I said in my previous post: There is an issue (which I would not call a bug, because the exported information is not wrong) and we’ll address it in the future. Till then, it’s unfortunately a shortcoming we’ll have to live with.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.