Export or Import not working


This is my first time here, so please be patient.
We have 2 Seatable installations in our System. First of all we have a 2.6 Version and another 3.0 Version.
At first I tried to export a new created Base without anything special in it from the v2.6 to 3.0.
The export needed some time, while the import on the 3.0 nearly needed none.
After I tried to open it, I got a red “internal server error”

So I searched for some solutions online, what should I say, maybe its because of the version difference. So, I tried to reimport a Base from the 2.6 Version back to the v2.6 Seatable… with the same solution.

Last thing I tried for fun. I wanted to import a Base from a higher Version (3.0->2.6) … Not so funny: I wasn’t able to press Export on the 3.0 Version.

Additional Information:
The 2.6 Version is connected to a FAAS-Server

Any Ideas?
Is it a Bug (can’t export 3.0)?

Thank you very much :grinning:

Usually, when importing/exporting does not work properly, the DNS configuration is not correct. You can test this by trying to access your server URL from within the “seatable” docker container. If this does not work, you need to fix the DNS issue first (i.e., hosts file, extra_hosts command in the docker compose, DNS server).

Why scapegoat the software if it is much more likely that your config is to blame?

It wasn’t my intention to blame seatable, just wanted to know if it was a known bug, sry.
Anyways thank you very much for your help, maybe you have a better solution but this one is it for me.

The Problem:
Seatable has to connect to itself via FQDN

go into container (docker exec -it seatable vim /etc/hosts)
/!\ You have to do this at every update, or docker up

Change your Firewall-settings and make a rule, so it is allowed to connect to itself

As I said above, there a multiple ways to address the problem.

Your workaround - manipulating the hosts file - is a quick and dirty solution. Dirty because it does not survive a docker-compose down.

My preferred solution would have been a custom modification of the docker-compose.yml: Compose specification | Docker Documentation. When using the docker.compose up command, the specified host is written to the hosts file in the docker container.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.