German number format not displaying despite being selected

I am using a formula to work out the gross/VAT/net prices.
the gross prices are the sum of three individual (gross) prices and the VAT and net prices are worked out from the sum of the three gross prices.
If you look at the screesnhot, you see that the linked prices display okay but the formula prices are an amalgam of German format (. as thousands separator) with the . as decimal separator.
What can I do to get the correct format? the format here is a number, not a currency. But teh same problem occurs if I change it to a currency (e.g. €).

Follow-up. do you already have a better way of extracting VAT from a numberß

You can go to the column Gesamtbetrag (Brutto) and select Format settings, and then set the correct decimal separator and thousands separator.

image

And then the results should be displayed correctly
image

Such a fine ready-to-use feature is not yet developed and I’m afraid it won’t be. Because using the gross price to multiply (0.19/1.19) is very simple already, right? :grinning_face_with_smiling_eyes:

1 Like

My settings are exactly the same as in your screenshot, but it doesn’t work the same. For example, you can see the format for the “MwSt” column. Bildschirmfoto 2021-12-16 um 16.32.37 .

i have opted for two decimal places. but the result is this.
Bildschirmfoto 2021-12-16 um 16.37.37.
The formula is “{Gesamtbetrag (Brutto)}/1.19*0.19”

I see! I have the impression that when you have changed the format settings, you need to wait for a few seconds. Perhaps you could try changing the settings to anything else and then change it back? And change decimal separator and thousands separator one by one. This is because the changes have to be written to the server and it costs a few seconds.

Hi Karlheinz,

I tried out your suggestion. It worked for one column with the following formula:
add({Preis K1}+{Preis K2}+{Preis K3})

However, for the VAT column and the other total column, it didn’t work.
Maybe an error in my formula?
The VAT column formula* is:
{Gesamtbetrag (Brutto)}/1.19*0.19 (it is not possible to change the figures to 1,19 and 0,19)
and the formula net total column is:
{Gesamtbetrag (Brutto)}-{MwSt}

*I tried alternative “divide(x,x)” formula but the same result. I think the problem is the VAT formula.

Hi webdienste,

thanks for your explanation. I don’t think the problem is with the formulas. As long as the formula result is numeric, it is not a problem for the formatting.

The format settings of the result could be tricky sometimes. As I said above, you could change the settings one by one and leave a few seconds between to let them take effect:

  1. Change the decimal separator and close the dialogue. The comma is used for decimal separation.
  2. Wait a few seconds and then open the settings again and change the thousands separator. The point is used for thousands separation.
  3. Wait a few seconds and then do the same for the precision settings.

image

I honestly don’t know why the application has such behavior, but that’s what I can show you for the moment! Of course, we’ll improve this behavior in the very near future.

Hi Karlheinz, Thank you so much for your reply. I tried something out: I deleted the problem columns, duplicated the column that was okay and re-inserted the formulas. And now it is displaying correctly! :grin:

I used a different browser (Chrome) to my normal browser (Safari) and noticed that the settings responded correctly, which didn’t happen in Safari. So, for example, the decimal point / comma setting didn’t change in Safari (the dialog box always showed the decimal comma even after selecting the decimal point) but it did in Chrome. Safari, huh…

Nice to hear! So I’m marking your last post as the solution.
And yes - we recommend using SeaTable in Chrome!

Super interesting! Never witnessed this kind of a behavior beforehand. Good to know for the future. Thanks for not giving up!

Just to add to this: It only worked when I deleted the column in Chrome and then added it again. But first I had to copy a column which was formatted correctly and then re-assign the column type.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.