How to check if duration value exists?

Hi @ll.

I’ve been facing an issue when trying to check if a duration value has been inserted or not. The following screenshot shows some formulas if’ve tried out. So what I’d like know is how I can identify empty duration values.

So here are the formulas for each column:

  • “gleich Dauer” > “{Dauer}”
  • “if-not” > not({Dauer})
  • “if” > if({Dauer}, 1, 0)
  • “text Dauer” > text({Dauer})
  • “value Dauer” > value({Dauer})

As you can seen if’ve also tried to convert the duration value but even for an empty value I get “0” returned.

Might this be a bug?

Kind regards
AkDk7

Do you use SeaTable Cloud or SeaTable Server? When SeaTable Server, which version?
What browser do you use? Please see Read before you post in User Talk

This is what I did:

  • The formula in "Echo column ‘Duration’ " is just {Duration} The result is formatted as a number.
  • The formula in “Is column ‘Duration’ empty” is if({Duration},"no","yes").
  • The formula in "Is column “Echo column ‘Duration’ " empty” is if({Echo column "Duration"},"no","yes").

The first row shows an unexpected result in all three formula columns. The other rows look fine.

@Daniel @Leo.Shi Looks like a bug to me. Can you confirm?

I am running a private server in version 3.1.13 and using Firefox in the newest version.