HTTPS from Cloudflare

Hello! First of all, I want to say I am delighted for the SeaTable app!

I installed a docker-container, configured the SeaTable app, created databases and tables, added a domain and configured Cloudflare – everything worked successfully, databases were opened and edited.

Then I installed the SSL-certificate from Cloudflare strictly according to the manual in the Deploy the https section on Deploy SeaTable Community Edition with Docker, and after that, the databases do not open – in the console I see error messages about CORS, and in the SeaTable logs there is nothing informative at all :disappointed:

Can you tell me if I need to change any other parameters when moving to https?

Hello and welcome to SeaTable Forum! And very glad to hear you are delighted for SeaTable.
Your question got me…let’s hope someone can answer this question soon!

1 Like

I discovered that it is definitely https. When I open any database in the list, the system pulls the http path and the browser blocks it.

Perhaps the nginx.conf is configured incorrectly or somewhere else in the configuration I need to change http to https, but I don’t know what.

Hi Ktgtylby, have you found a solution to this issue? Thanks.

Hi Ktgtylby and unidesigner2020!

I had the same issue and finally fixed it.

In the Add your own SSL certificate manual the 2nd step is currently «Change the “http” of each SERVER_URL in ccnet.conf, dtable_web_settings.py and dtable_server_config.json to “https”».

In fact dtable_server_config.json has no similar settings, ccnet.conf has SERVICE_URL, and dtable_web_settings_py has DTABLE_SERVER_URL, DTABLE_SOCKET_URL, DTABLE_WEB_SERVICE_URL and FILE_SERVER_ROOT.
After changing each of these settings from the format “http://[ip-address][…]” to the “https://[host-name][…]” and restarting the service, all databases started to load without any errors.

Thanks Vadim! :wave:t2: