Installation of full server behind reverse proxy not working

Hello !
We have just installed a SeaTable server (the new “seatable-compose” way). It’s running on our unique Docker server (not alone there … ) and I had to change the ports 80:80 to 8085:80 and 443:443 to 4435:443 to accomodate for that. The server has IP 192.168.1.96. The reverse proxy does it’s job nicely at taking away IP:port from our few (MUCH) less tech-savy ones : seatable.local.
All the admin page, user creation and all work great … as well as table creation actually…
However, when trying to access a base (http://seatable.local/workspace/2/dtable/Test/) … We get greated by a “Network error” … digging a little deeper, it turns out it tries to reach the dtable server via :
https://192.168.1.96/dtable-server/dtables/fd137eff-4ee7-4f07-adcd-b6093598c375?lang=fr
… which obviously won’t work … ( [1] : https not configured : it’s only internal with no access from the outside … and not really sensitive informations … [2] : it’s trying through the IP ??? (how and why ??) [3] : the port 80 … obviously won’t work … )
Any way we could change that for a parameter in the .env ??

here’s our current .env for reference:

# use developer edition
SEATABLE_IMAGE='seatable/seatable-developer:latest'

# components to be used; IMPORTANT: there should be no space between the files names !
COMPOSE_FILE='caddy.yml,seatable-server.yml,python-pipeline.yml'
COMPOSE_PATH_SEPARATOR=','

# system settings
TIME_ZONE='Europe/Zurich'

# seatable server url
SEATABLE_SERVER_HOSTNAME='seatable.local'
SEATABLE_SERVER_PROTOCOL='http'

And then the username/passwords, …

Thanks in advance for your help and guidance!

Check all configuration files of SeaTable Server and nginx. You will find the wrong value. Replace it and restart SeaTable Server.

Explanation:
I assume that you changed the .env values after the first startup, right? Some values are only used for initialisation.

Ohhh … I’ll check in that direction and get back to you !! Thanks a lot for the very fast reply !!!

Hi !
Sorry for the delay we had a big internet outage due to a storm …

Ok, it all worked out (since we were just starting [noticed the problem when creating the first tables] … I simply wiped it all out and set it all up again) now working perfectly, as intended !
Thanks a lot for your explanations, your ()very quick) support and great help !!

My colleague left a nice comment on trustPilot

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.