Migration of a single base to another docker setup

Hello, I have a base which we have been using for a few year and data is quite huge ( I guess, since i am unable to export out the base )

when i try to export the base, i get the following error.


May i know if there is any way i could migrate this base only this base to another server? ( which has a different domain )

secondly, since the data is huge, i make a copy of the base, delete all records as shown below,

and try to export again, but it is still showing me the same error.
I am trying to export base as i do not wish to recreate all columns and formula, forms in the new server.

If i am able to migrate the records, it will be the best. However, i am happy if i am able to create a new base from backup file without records.

I guess history data exist even though i have delete all records.

may i know what is the best possible solution to solve my problem? :grinning:

From the error message, you should delete the attachments (files and images) of the base, instead of deleting the records in the base.

Hello @daniel.pan by deleting the records, isnt all the files and attachments are deleted as well? since there is nothing left in the base

by the way , i forgot to mention in my previous post of my setup . and will connecting to seafile through api transfer the photos and attachments and reduce the size of base?


Attachments are not deleted when you delete the records, because attachments can be referred from different places:

  1. The snapshots are still refering attachments.
  2. A same file can be referred by multiple deferent records in different tables.

The attachments need to be deleted manually.

I will be deleting this 2 column manually by pressing “delete” button on my keyboard.

after i delete it and try to export the base, it give me the same error.

i try deleting the 2 columns, but i am getting the same error when export.

lastly, is there anyway i can delete the snapshot?


as Daniel mentioned previously, files cannot be deleted from a base by deleting the entry.

Please follow the instructions for this.

@fsa thank you for your guide…

as shown above, i am unable to locate the file management as per manual.

However, i do manage to find it at the location shown below. so i guess it will solve my problem… :grinning:

Ah, I just saw on your screenshot that you are still using version 3.5. Our instructions refer to the latest version.

Nevertheless, I’m glad you found the menu. I hope it solves your problem.

i have upgraded my version to 4.0 , delete all files from the “file management”

however, when i try to export the base, i am still getting the following error

I have increased the max file size as well. but it is still not working

Can you check what error message you have in dtable-events.log and dtable_events_io.log?

hello, for dtable-event.log, i get the following error

for dtable_event_io.log, i get the following error.

please let me know if you require more information.

hello, i think the error is unable to create the folder?

I don’t know the exact cause of the problem in your server. But in version 4.1, we will ignore such kind of error and make the base content can be imported.

1 Like