No initial zero possible in number format?


I have noticed that numbers that start with a zero are not displayed correctly. German postcodes and area codes start with a zero. However, these are omitted in the number format. Is it possible to allow a starting zero when using the number format? Or is it mandatory to create such numbers in text format?

Thanks in advance!

Hi, the number type is supposed to be calculated, so I think you don’t need to use number type for the postal codes. Using text won’t bring any disadvantage, right?

Yes, it can also be text. I can’t think of any use case of calculations with postcodes or telephone numbers at the moment.

The problem: I have imported a table. The columns with the telephone numbers were automatically assigned the text format. But the postcodes were given the number format - without a starting zero. So now I have to convert the corresponding columns into the text type and then give all the postcodes a starting zero. It would have been nice if I had been spared this :pleading_face:

That’s a good point! Indeed, when importing from Excel, the postal codes could be recognized as numbers. “Choose column types when importing from Excel” is on our feature request list. With each user feedback, the feature request gets a higher priority!

Thanks Karlheinz!
It would be even better (or an addition) if one could select or deselect the initial zero at any time within the number format by option.

You are very welcome! This reminds me of a feature of the number column: You can set a prefix for the numbers. If all of your postal codes begin with 0, you can use this feature: set it up as Currency and use 0 as the currency symbole:

And then as you type e.g. “3485” you will get “03485”:

But as said, this only works if all your postal codes begin with 0. Otherwise ignore this post!

Thanks for this workaround!
You have saved me a lot of work with it :relaxed:. My imported postcodes now all have a starting zero.

Regarding your first screenshot: This is also where I would put the option I mentioned.

You are welcome! Glad to hear that this workaround helped you. I’m marking this topic as solved then. The feature request is also documented.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.