Not all column types displayed when creating new records from "link to other table" column

I noticed something stange, but can’t recall whether Seatable behaved differently in 3.x:

Scenario: Column “Link to other table” => “Create record” to implicitly create a new record (and link it) in the target table. Not all columns from the target table appear in the form to create the new record.

  • Links to other tables: There might be an intricate logical condition (cannot link something that hasn’t been created yet) to prevent that, so I can live without that
  • However, rating fields don’t appear, and I can see no reason or documention why this is the case
  • Haven’t checked many other field types apart from Text / Number / Long text / Date (all work), so let’s check whether the missing rating field is a single exception.

We will test and report.


you are right, the column type “Link to other records” and the option “Add record” do not allow to add the column type “Rating”.

I have performed a full test:

Column type Add linked records
Text yes
Long text yes
Number yes
Collaborator yes
Date yes
Duration yes
Single select yes
Multiple select yes
Image yes
File yes
Email yes
URL yes
Checkbox no (should be yes)
Rating no (should be yes)
Formula no
Link formula no
Geolocation yes
Creator no
Created time no
Last modifier no
Last modified time no
Auto number no
Button no
Digital signature no (should be yes)

We will forward the result as an issue to our developer team.

We will fix the problem in version 4.1.


Hi, thanks for checking and reporting to the development team!

While using Seatable 4.0 after having reported this, I discovered that another column type seems to be missing, both from the “Add record” form and your list: “link to other records”!

Luckily, I’m still running a 3.x test server to double-check: Linking to existing records from the “add record” dialog was possible there, too. I can understand if there might be concerns that an inifiinite “Link - Add - Link - Add - Link - Add …” chain could develop that nobody understands, but linking existing records at least should work in my opinion.

I’m using more and more data structures where tables are linked via an intermediate table, to create more complex relations, bearing additional meaning. (I think this also contributed to the “Don’t show button ‘Link existing records’” option to force the creation of new intermediate records.)

However, not being able to link or create records from the “Add record” option makes this a very tedious process: “Link record / Add new” in first table => go to table view of second table => find that newly created record => link to record in third table.

A fix would be very much appreciated!

Is this also implementable @daniel.pan ?

We will give it a check. It should be also fixable.

Hey @abaer.

good news, our test environment is already running the latest SeaTable version and I can tell you, all the column types are now supported.

From checkbox, rating, Signature to link to other records.

So, with the update to version 4.1, which will be released soon, you can use everything as usual again.

1 Like

Great to hear, Thanks! It turned out to be a real pain to work around this issue during the last few days, so this is excellent news!


@abaer We have updated SeaTable Cloud to version 4.1 today.

The link column has got a lot of attention in this new release:

  • The link column is now watchable in automations
  • Modifications in link columns are tracked in the row details
  • SeaTable’s bar charts now support link columns
  • The “Add record” dialog now shows all relevant column types (the problem discussed in this topic)

Would you be so kind and test if the update has solved your problem?


Hi, I was only able to do a quick test in specific places where I knew these things occurred, and the result are positive - thanks!

  1. Confirmed in 2 cases that worked right away
  2. Didn’t know it was missing, but a great addition :grin:
  3. Same as 2., even greater
  4. Confirmed working!

GREAT! :star_struck:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.