Numbers not displaying correctly in PDF but fine in Page Design (2)

Following on from this thread (Page Design OK, PDF with errors - #2 by rdb), I am afraid to say that a number of aspects of it are still problematic:

  • The numbers are rounded down
  • The 2 decimal points (here comma) are not shown in the net sum, VAT and gross sum entries but shown in the individual product entry
  • A concatenated string has 2 euro signs, one before the number and one after (the one after the number was part of the concatenate and was desired) in the net sum, VAT and gross sum
  • Everything displays correctly when printing, just not when creating PDFs.

I think the issue could be with my formulas, so here is an example:

Gesambetrag netto” comes from the sum of three products (in the example, only one is shown):
Column name: Gesambetrag (netto) Privat
Formula: sum({Übertrag K1},{Übertrag K2},{Übertrag K3})
Bildschirmfoto 2023-09-04 um 17.28.36

The result is then concatenated as a string in the column : G-betrag-Format-privat
Formula. concatenate({Gesamtbetrag (netto) Privat}," €")
Format setting: string
This column is inserted into Page Design to display.

For your info:
“Übertrag K1” is the sum of the price column minus a discount column. The displayed text in Page Design comes from a formula that is concatenate({Übertrag K1}," €"). The same applies to Übertrag K2 and K3.

What is going wrong? Why does the price next to the product display ok but the net sum show 2 euro signs and round down the number and not show 2 decimal points? I have looked at my formulas and the columns that are okay are built in exactly the same way.

I am not encountering any such issues:

Total net, discount VAT and Total gross are formula columns formated as currency:

Why don’t you format the result as currency? (Also saves you one column.)

Hi Ralph,

Your suggestion of formatting the column as a currency (in my case a custom currency as the “Euro” option displays the symbol before the number) does solve all of the problems. However, the currency symbol is displayed immediately after the number (e.g. 840,34€). I would like it to display as 840,34 €. How can I achieve this? I don’t see any obvious setting.

Unfortunately, there is no option to add a space between the amount and the currency symbol. We may add this in the future.

Thanks Ralph, I will go with the option of € sign directly after the number

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.