Page Design plugin. Duplicating the first page

Good afternoon! I started to master the “Page Design” plugin and faced the following problem:

  1. The check mark “Auto-expand if placeholder does not fit all records” is set on the table block, but when printing and saving to PDF, I have 7 copies of the first page instead of all the table entries.

  2. I have not found whether it is possible to transfer to the second line in the table header row?

Can this be fixed?

*I use self-hosted version. Plugin version 1.2.2. Overall, the plugin is very good (like the whole system)

Please tell us which browser you use and how exactly you print. Do you print via the “Print” or the “PDF” button?

I used “Yandex.Browser” and “Google Chrome”. I tried to print to the printer (Print) “Pdf”. And already in the preview mode, the pages are duplicated regardless of the printer model - PDF or HP, Xerox.

I tried saving it as a “Pdf”. Only the first sheet is saved as it is formed on the layout.
The document form is provided only as landscape mode. But in book mode, the problem repeats.

Please use Google Chrome.
I don’t know anything about Yandex Browser, let alone do we test with it.

For best results, use the server-side print via the PDF button. SeaTable cannot control what your browser, OS, local printer driver does with the document.

I am not sure what you are saying here.
Please re-try printing using the “PDF” button. You can set the page format in the page’s settings.

I think I found the reason. It was repeated both on our server and in the SeaTable cloud. When the “Auto” checkbox is enabled in the “Font and row height” menu, what happens is described above. If I turn off this checkbox, the table stretches and goes to the next page with a sufficient number of entries. When enabled, it crashes.

And one more thing. When you select the “Print” button, the plugin makes as many copies of the page as there are rows in the table (in my example, 30).

an example of my database with plugin settings:

Good afternoon, tell me, do you confirm the problem, is it repeated with you?

PS: Yandex is a good browser, try it)