Page plugin - table settings incomplete

Hi, when I add a table to a page, and set it to “auto hight” for the columns as well as “auto expand, if placeholder does not fit all records”, the tables are not properly expanded, but only the content visible in the placeholder is shown. If I unselect the “auto hight” for columns it works again.
Can this please be fixed?

also would be great, if the page design would offer a “renaming” of colums, the same way as you already support it in forms, especially when designing an externally facing document (like an invoice) the column header names might not always be accurate.

Another nice function would be to be able to place fields from a linked record independently (like a customer’s adress) and not only in the table format, in which it is linked, without having to add lookup formulas for each linked record and all fields.

and if the tables expand correctly, they overlap with other content as the content below is not properly moved down with the initially defined space between elements. Am I missing a setting?

1 Like


you are talking about setting the “Row height” to Auto under “Font and row height” and also using the “Auto expand” function. This combination is not possible and a corresponding message appears, the switch cannot be activated and the option is grayed out:


Can you please provide a screenshot of the overlapping content? Then I can take a look at it.

Hi, that is unfortunate, that it does not work in combination, as both is needed to ensure complete visibility of table content on a document, e.g. an invoice, thus might be a very useful improvement to the plugin, else it does not to be useable for a great number of usecases with varying number of entries and texts.

attached the screenshot of the downloaded pdf, vs how it looks on the page designer (auto expand is active for all 3 tables):

This means that several view elements “all records in view” are integrated in the page design, correct?

And as soon as the PDF is created, entries are displayed on top of each other?

Does this only happen when auto-expand is activated?

just tried, for some reason exporting currently does not work for me at all, but I took out the setting an in print preview the tables don’t overlap but are shown as set up with limited entries in the page design.

I can print and also export as PDF.

Could you please give me more information about my questions, I need to be able to reproduce the behavior so that we can find a solution.

HI, I though I replied already, that the overlap does not happen, when auto expand is de-activated, as then only the 2 entries are shown, which I limited the area to in the page design. I did not see it when exporting a pdf, but in print preview.
basically, when auto expand is activated the upper position stays as it is for all elements and tables are just expended on top of the lower content as seen in the first screenshot.

I still cannot test the exporting of the pdf, as it does not seem to work for me anymore.

”Auto hight“ and “auto expand" can not work together. It is unfixable in the page design plugin.

In this year, we have a plan to add another plugin for document/report creation that can work better with float (non-fixed height) elements.

1 Like

looking forward to that next document plugin then!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.