Pdf open is asking for login but download is not asking for login

I have created an Universal App. The App is set for Anonymous access and without any password.
The app is opening without asking for any login. I am generating PDF through button and saving it in the column.
When I try to open file from the column it is taking me to the login page, however I can download file without login.
Can you please help if there is some configuration change need to be done to remove login page when clicking on file link?
Screenshot 2024-02-11 at 8.28.44 PM

First of all, please provide the full information:

  • Are you self-hosting or using SeaTable Cloud?
  • If self-hosting, which version do you use?
  • Which browser do you use and have you used other browsers.
    (All of this is captured here: Read before you post in User Talk)

Secondly, please provide a consistent description of your problem.

As far as I interpret this, I can be one or the other. Not both.

Sorry I forgot to mention these details.
I have latest Enterprise edition 4.3 hosted on my own cloud. I tried with chrome, safari and duck browsers.

Please refer the screen recording from here: JioTransfer | Jio Transfer | JioCloud

  1. Clicking on file to view file in browser is taking to the login page
  2. Downloading file is working without any login

I tried with multiple files, also duplicated app and base to check behaviour but still problem persists.

Please see how to remove this login redirection.

Thanks in advance.

The saved documents are stored in SeaTable’s file management. If a SeaTable user clicks on a document in the Universal App, the preview opens via the corresponding link.

If non SeaTable users click on the document, they will be redirected to the login page, as the preview cannot be displayed, but the download is possible.

Therefore, it is not intended to remove the login.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.