Printing a Long Text field of a selected row?

Hi all,

Really like all the features of Seatable and the flexibility of Buttons and Scripts!

But is it possible to print a Long text field of a selected row from the GUI or from a javascript?
This way I can print a welcome letter or whatever letter for a selected person/row (using regex to change placeholders to CurrentRpw.values)

The new print (seatable 2.1) is nice but print all records in a view as a grid.

Kind regards

Hi FolkertH,

welcome to the SeaTable Forum.
Have you tried the Page Design plugin? It’s a really powerful publishing tool and can turn your rows into nice pages.

Just add it to your base and then open the Page Design plugin and place the long text field on the page, adjust the style and print it to paper or to PDF.

Hello Karlheinz,

Thanks for your fast answer.
Page Design works very nice. As an admin I can use it to design nice, personalized letters to a selected row/member. But is it possible to use a Button-script on the selected member-record to directly print a Page Designed letter for only that selected Member?


This is possible! I prepared a little how-to to demonstrate it (to enlarge the video, right click it and open in a new tab):


I stopped the video when the printer settings pop up appears. Then you can print the document either on paper or as a PDF.

Anticipating a follow-up question: Unfortunately, you cannot create a PDF using the page design plugin and save it straight in a file column in a SeaTable table. This is not supported yet.

Thanks @rdb for the video. And yes - with the button you can open the page design for the current row, which is really amazing in SeaTable 2.1.

As per the PDF export feature - with only two more clicks, you can choose print to PDF in the system printer settings and get a PDF - so this is not an issue for now! Anyway I heard we are developing the “export to PDF” feature.

Hello Ralf

Thanks for your movie and pointing me to this new action “open print design” behind a button.
But If I follow your instructions and push the button I still get the value of the Name field of the first record in this table in my letter instead of the name of the selected row. I am doing something wrong?

Kind regards


glad the video helped you!

I have two possible explanations for the observed behavior:
1.) Do you self-host SeaTable? If yes, please update to SeaTable 2.1.
2.) Did you embed the name field as a “static element” rather than a “table field”?

If the base does not contain any confidential/privacy-protected content, please send an invite link for your base to I will have a look. (More about invite-links here.)

If you are running self-hosted, remember to update the page design plugin at the SeaTable Plugins Market

1 Like


It is getting weird, the screen freezes after pushing the button to open page design for a named design.
I am on newest Chrome on Mac osx Mojave using the Seatable Cloud version.
I need to refresh the browser (cmd-R) to make Seatable responsive again. Other Chrome tabs are still responsive, only Seatable is frozen.

Just checked: Safari gives the same issue. Table freezes after pushing the button to open page design


Obviously, this is not the desired behavior! My guess is that it’s a problem in the page design plugin.

Why? I encountered the same behavior during some early tests with the page design plugin. We thought we had fixed the problem, but maybe we haven’t?! A corrupt template in the page design plugin was the cause of the problems we observed. The corruption became apparent when exporting the template. Rather than a well-formatted JSON file, the export was a mishmash of code. Can you check this? If the template is corrupt, just delete it and create a new one. Sorry for the inconvenience!


I removed the page design plugin and then installed it again. The freezing of the table is gone.
I can select another row again and push my print button again. But every time it prints the letter for the first record in the table.


Sorry for this! We’ll look into it.

I am at my wit’s end with your problem. I cannot explain it.

Could you send an invite link for the base in question to support@seatableio (as described above)?

Hi all

It works again as expected. Pushing the button selects the current record for printing :smiley: