Problem with Email Config - v3.3.0

Hi! I’m having issues to send emails from my server. I’m trying to send reset password mails but all I get is the notification that the email settings are not properly configured.

EMAIL_HOST = ''                                # smtp server
EMAIL_HOST_USER = ''    # username and domain
EMAIL_HOST_PASSWORD = 'XXX'.             # password

Not sure what the issue is. I tried with TLS True and False, restarting seatable… no difference. I can send emails from any client using the same credentials and port also with other services, so I don’t see the email server at fault.

Any ideas what the issue could be?

Please remove the dot at the end of the EMAIL_HOST_PASSWORD line.

If you still cannot send emails, please use a tool like SWAKS to test your configuration.

1 Like

That would have been great if the dot was it! Unfortunately, that was just me not deleting the password properly.
I wiped everything and did a clean setup but still the same issue.
Will test with SWAKS now. Thank you for the suggestion!

Please also check the logs of your SeaTable server. Execute these commands and then try to send an email. Usually, you will get some more info what happen at the server.

cd /opt/seatable/seatable-data/seatable/logs
tail -f *.log
1 Like

With SWAKS I found out that I was wrong to claim that sending emails from port 587 works in general. The server is managed with Plesk and even though it uses TLS to send emails, it’s sending them on port 25. Didn’t even know this can work.

Thanks for the help, wasn’t related to Seatable at all :slight_smile:

In case someone has the same issue, this is how to test with swaks. In most cases it won’t be necessary but testing can be done directly from inside the docker container.

$ docker exec -it seatable bash

$ apt-get install swaks

$ swaks --to --from senderemail --server yourmailserver --tls --port 587 --auth-user sendermail --auth-password "yourpassword" --header "Subject: test email" --body "This is a test email"

I didn’t specify the port at first and the mail went through with tls, so that’s something to look out for!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.