Reset export setting

Hello,
as Export via dtable does not export images/attachments has been closed and marked with solution that was no solution I open the topic again.
How can I reset the setting that also attachments should be exported? (Export size limit is high enough)

1 Like

Hello Michscha,

I have just tested the export and import of a DTABLE file under the current SeaTable version and cannot reproduce the behavior you describe.

The import works smoothly and all files are displayed.

Which version of SeaTable are you using (cloud, on-premise)?

Hi,

thanks for your response. Currently using v4.2 but when trying to export a base with attachments I only get the content of the table but no attachments exported.

Today we released v4.4. Please update and try again.

Due to the issue that the export does not work I won´t update currently. In the other thread it was mentioned that there is some kind of “hidden” setting that is stored somewhere which reflects if a export does cover attachments or not. Where and how can I reverse that chosen entry?

There is no such reset. The only option that I see is to export the base from the command line:

$ docker exec -it seatable-server bash
$ cd /templates
$ seatable.sh python-env /opt/seatable/seatable-server-latest/dtable-web/manage.py export_dtable 59d2cd47-ba2f-42ad-9c90-08f13a6b5738

For sure you have to replace the base_uuid. You can also pass the parameter --ignore-asset true/false.

Thats somehow strange. Using your command with the correct uuid including the flag set to false does sill export only the table itself.

Attached a screen that there are attachments which I also can see in the filemanager

Any idea? :wink:

Upgrade to latest version.