Restoring the SeaTable data doesn't work

Hello SeaTable Team,

I’ve tried to restore backups (databases and SeaTabe data) in the version 2.0.0 using

After that the error “Library does not exist.” occurs when I open the existing base from backups (The base name is there but empty) or when I want to import a base from a .dtable file into SeaTable (Library c3… not found). However, I see this Library ID as a directory in seatable/seafile/storage/fs/ of my SeaTable data volume. There is no problem with user or group list. Databases seem to be restored . The I suspect that problem is due to the step of restoring the SeaTable data. Do you have any idea where I went wrong and how I can fix it?

Another question: In the step “Restore the databases” of the above guide I saw it. Could it be a mistake or is it a on purpose? For my test above I have customized it.

docker exec -i seatable-mysql /usr/bin/mysql -uroot -pMYSQL_ROOT_PASSWORD ccnet_db < 
docker exec -i seatable-mysql /usr/bin/mysql -uroot -pMYSQL_ROOT_PASSWORD seafile_db < /opt/seatable-backup/databases/ccnet_db.sql
docker exec -i seatable-mysql /usr/bin/mysql -uroot -pMYSQL_ROOT_PASSWORD dtable_db < /opt/seatable-backup/databases/ccnet_db.sql

Thank you very much in advance.

The information provided leaves a lot of room for speculation. So let’s do it:
a.) Are you sure you copied the the seatable data in the correct directory? (If you didn’t, it is not surprising that the bases cannot be found.)
b.) Does SeaTable have access to the seatable data? (If you copied the files using root, the permissions are probably wrong.)

One thing seems pretty obvious: SeaTable does not have access to the seatable data folder. If the import of a dtable file fails, there you have it.

Can you specify what you mean?

This is a typo. I have fixed the document.

Thank you @rdb for your answer. I think the problem could be the permissions as well. Which user-id or group-id should have the seatable data or how could I figure it out?

The file names were incorrect in restoring commands. @daniel.pan has corrected
the documentation

Cool, thank you @daniel.pan

When I start SeaTable from scratch without backups, I see all folders in the seatable volume have root as owner. I can also import a base. So I can not figure out to which user I should change

It works now. I think in my case I removed the directories ccnet, logs in the seatable data backup but I didn’t clean them in the current seatable volume.

Glad to hear that you could solve your problem. Can you mark as solved?

Is your other topic also solved?

Thank you @rdb. Could you have a look at my other topic? I have there another question of extra notes.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.