SeaTable 2.6 out now

Great news, we deployed SeaTable 2.6 on SeaTable Cloud. Please check it out and give feedback!

These are the highlights of the last release in 2021:

  • Private view : Create views only visible to you, change view settings without affecting other users (for SeaTable Enterprise only).
  • More default values : Define default value in three additional column types bringing the total number of columns supporting default values to six (i.e., text, number, single select, rating, checkbox, long text).
  • Improved page design plugin : Design multi-page templates and print them as PDF, add linked records in tabular form.
  • Data update with CSV/XLS : Update your data in SeaTable using CSV and XLSX files.
  • Customizable table header: Make room for longer column names by wrapping them to two lines and hiding the icon for the columns’ context menus.

Intrigued? Have a look at the Release Notes for more information about this great release. Or browse our Changelog for a complete list of changes - major and minor.

Self-hosters will be able to download SeaTable 2.6 from Docker Hub as of now.

Extra note for self-hosters: SeaTable Server Enterprise Edition 2.6 introduces a license file requirement. The server will not start until a license has been provided. We offer 3user, 2 year licenses free of charge upon request on our website.

The SeaTable team wishes you a wonderful festive season. Stay safe and stay healty.


Applause all around!!!
Multi page templates and default value just solved our dilemma of generating complex work order designs for our printing production teams!!

We are going live with our test run end of January to see how seatable fairs managing high volume screen printing, digital printing, and embroidery workflows and this update was key. Utilizing 81 columns minimum to store art specs across multiple departments is a nightmare that had us frozen for two weeks as we would quickly reach the 500 column limit while trying different setups between the tables. Long text default value will provide us a way to add a short template that is manageable to standardize art spec input based off a “template” in one paragraph block that will be easy to manage on page designer.

Well done!!

1 Like

Thank you for your kind words.
I’m writing to announce that the

are also revised and updated to comply with the latest 2.6 version.

Just to know, that means that there will no longer be a free version, for more than 3 users??
Or DE edition stays as before, without license?

SeaTable Server Developer Edition does not require a license.

Thanks for the hint. I have rectified the post by adding “SeaTable Server Enterprise Edition introduces a license requirement.”

1 Like

That was actually also my concern. As a DE user i was hoping to get the 2.6 release also via Docker, but this repo seems not to be updated.
Will there be an update of the docker image for DE, or does that imply an migration to the Enterprise version?

There has been a new docker image in Docker Hub for more than 20 days:

1 Like

Thats true, but not here Docker Hub

Is there anything I need to consider, when I change the container in my docker-compose? Or do I just do a

docker-compose pull
docker-compose down
docker-compose up -d

followed by the start-up script.

1 Like

Was this ever resolved? I would also like to update with the method you describe.

No need to rely on the Forum for update instructions.

There is a detailed update tutorial in the SeaTable Manual.

just wanted to give you a reply on that,

All-though i have followed the instructions in the online manual, i again totally botched my SeaTable DE installation, and lost all my bases. As this happened the third time in a row, while upgrading my docker container, i gave up selfhosting of SeaTable and migrated all my bases to I really like SeaTable, therefore i’ll try to work with the SaaS version.

Hi - well, I have been upgrading for a year with a simple docker-compose pull, and now I can’t, so maybe there should’ve been a heads up about that. Also, according to the comment of @mfreudenberg the situation is not so easy.

Looking at the manual, my docker-compose file is pointing to seatable/seatable:latest. I suppose I somehow need to switch from this to seatable/seatable-developer. (At some point you changed the docker-compose file to point to this.)

Now my question is, following the experience of @mfreudenberg , can I just rewrite seatable/seatable:latest to seatable/seatable-developer:latest in my docker-compose.yml? Or will this break things? For sure I don’t want to lose all my bases…

Backup all your bases beforehand. Just do it. I hope you don’t have that many :grin:.

I think starting witb SeaTable 2.6, they switched the docker hub image. So you’ll have to pull from a different repo if you’re a DE user. Can’t tell you currently, which repo that is. As i am on my phone i don’t have access to my docker-compose.yml.

Just backup your bases and give it a go. I’d be curious to know, if uou succeeded.

OK, it seems to have worked without a problem. Thanks for encouraging me. @rdb consider this resolved, but it would be good to maybe make a note in the docs that the docker hub location has changed, so that people don’t get stuck on 2.5 like me.

Would you mind sharing your docker-compose.yml (with masked credentials and ofuscated paths etc)? I’d be curious what i did wrong. We could also create a new post for that.

@mfreudenberg sure - see below my current docker-compose.yml – the only change I’ve made was change seatable/seatable:latest to seatable/seatable-developer:latest. (Actually, I first changed it to 2.6.0 not latest, so that I do one upgrade at a time.) Hope it helps.

version: '2.0'
    image: mariadb:10.5
    container_name: seatable-mysql
      - MYSQL_ROOT_PASSWORD=xxx  # Requested, set the root's password of MySQL service.
      - MYSQL_LOG_CONSOLE=true
      - /opt/seatable/mysql-data:/var/lib/mysql  # Requested, specifies the path to MySQL data persistent store.
      - seatable-net

    image: memcached:1.5.6
    container_name: seatable-memcached
    entrypoint: memcached -m 256
      - seatable-net

    image: redis:5.0.7
    container_name: seatable-redis
      - seatable-net
    image: seatable/seatable-developer:latest
    container_name: seatable
      - ""
      # - "8587:443"  # If https is enabled, cancel the comment.
      - /opt/seatable/seatable-data:/shared  # Requested, specifies the path to Seafile data persistent store.
      - DB_HOST=db
      - DB_ROOT_PASSWD=xxx  # Requested, the value should be root's password of MySQL service.
      - SEATABLE_SERVER_LETSENCRYPT=False # Default is False. Whether to use let's encrypt certificate.
      - SEATABLE_SERVER_HOSTNAME=xxx # Specifies your host name.
      - TIME_ZONE=Europe/Prague # Optional, default is UTC. Should be uncomment and set to your local time zone.
      - db
      - memcached
      - redis
      - seatable-net
    #command: sh -c "/sbin/my_init -- /templates/; /shared/seatable/scripts/ restart"


Hi @mkoutecky,

sorry for the long delay in my response. Meanwhile, i have installed 2.8 on my homeserver. I runs ok. My docker-compose.yaml looks very similar to yours - so thanks for posting :+1:.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.