Self Hosted / Docker access MariaDB MySQL

Seatable EE 1.8.2 - Self Hosted / Docker
I have tried to access the database from external using HeidiSQL and Port 3306
There is no my.cnf, how/where do I need to allow external access to the seatable mariadb / mysql ?

Hi, could you please advise how this can be achieved?
Thank you

Not entirely sure what you mean:

I would like to access the seatable mysql database with e.g. HeidiSQL from external. I was trying with HeidiSQL to access the seatable database using the server IP Address, port 3306 and the msql credentials but no connection.
Where do I need to allow external access to the mysql database?

Let me summarize:
a.) There is a my.cnf that you can modify (as you can see form the screenshot above and contrary to what you say)
b.) MariaDB/MySQL listens on port 3306 (as you can see from the screenshot above)
c.) MariaDB/MySQL is not listening to the outside world (looking at the screenshot above, you can see that the docker container listens to, whereas MariaDB is only 3306)

Well, the problem is obvious. Solution: You must tell the MariaDB container to listen to incoming requests from beyond localhost.

You do this via the docker-compose file. Add “ports: 3306:3306” to the instructions for the seatable-mysql container. Run the modified docker-compose and check with “docker container list” the difference. Needless to say: If you have any firewall in between, open port 3306.

Thank You very much for the help, works great

1 Like

mtmail any chance you can share how you were able to connect? ive been trying to connect via sequel pro on Mac, verified my port 3306 was accessible, however still can’t connect via the IP, port, username, and password

I did the same thing before so I post it. As rdb mentions, you just have to modify .yml file to enable port forwarding 3306:3306 so that VM’s port is transfered to Docker port(it’s like a NAPT of router). Otherwise, Maria db cannot be connected from external host.

1 Like

I’ve done that as you can see in screenshot below.

Using sequel pro ive tried with my public IP as host(only default values are shown in screen shot below), username root and my password set in the compose, port 3306, left database blank and tried dtable-db, still no connection and timing out. Any ideas

ok so got it to work. missed the firewall access. now that that’s done, I can see all the dtables as they are listed in their own table as records in the entire database, but wondering how to query data from the specific bases/tables