Signature field does't work on my phone

I have a table with a signature column with a form for it. Now when I want to fill out this form on my phone and I give my signature, it just says, “Saving…” and nothing more happens. I can’t come back and submit the form. What can I do there? Is this a Seatable bug?

I have an iPhone 11 with IOS 16.0.2. And I tested it on the Safari, Chrome, Edge and the Google app

That’s what my phone shows after creating a signature:

Hi Lukas,

i just tested the digital signature on the iPhone and there was no problem saving.

The issue has not been reported to us otherwise.

Could you please test it again and let us know if the issue still exists?
Thanks in advance

Hi fsa,

I just tried it again, and it still hangs on the save animation. I’ve updated my phone to the latest IOS and the same thing happens. I don’t know what to do.


Dear Lukas,
I tried on all the mobile phones we have in our office. I have, for example, an iPhone SE with iOS 16.5.1.
I tried with Safari and with Google Chrome. I tried with data protection mode on and off.
In every case, it worked as it should.
As long as I have not device where I can reproduce your problem, I don’t know what to do.
Did you tried to restart your device?

Hi cdb,

I tried it on different phones(iPhone X, 11 on different IOS version and on a Samsung A52s on Android version 13), I restarted the iPhones, I updated the IOS, I even tried changing the language and location to the US (because I’m from Germany as the person on the other thread who has the same problem as me) but that didn’t work either. I don’t know if it could do something with the different location, language, time and number format. (well, that was my original idea because I had a problem with the German datetime format, where Seatable always changed the date when I tried to enter one via API)

I noticed that it works on my iPad.

I also tried it on a paid and on free plan, both doesn’t work.

Here is the Link to my form, if the bug is only caused by the form. You can test it how much you want, there is no sensitive data.

If you need any further information, just let me know.

Edited: I noticed that the button on the iPad (where the form works) says something different from the button on the phone (where it doesn’t work).

I just found out how to recreate the problem on the PC. Depending on the window width, the form changes due to the responsive design. On a wider window, the button for saving the signature says “Save” and on the narrower window it says “Done”. And by inspecting the buttons, you see that both buttons call different functions. Could this be the problem?

In this video, you see the different buttons and functions:

1 Like

I also have this problem. On a Samsung S23 phone using the Samsung Browser when I sign holding it in lanscape orientation it works, and the signatiure is stored in the Base. In potrait modus it hangs on “Wird gespeichert”.
But still, on a iPhone SE the Landscape orientation does not work. Might the display resolution be the reason?

We have received similar error reports from other users. We are investigating the issue and will provide a fix in a future release.


It is likely caused by anonymous users can’t work with signature field in version 4.0. This will be fixed in version 4.1.

Good morning. Just my 2 cents to the issue: On my Galaxy tab 6 in secufox browser, i also have the issue, that it would stop while saving. I have a form, with a sign field. If I manually load the page as “desktop page” through firefox options, it works. Same, if I change orientation from portait to landscape by turning the device, before I fill in the signature.

Obvious reason: The change in format, as in landscape, there is another control used for the signature, than for portrait orientation.