Table doesn't load, loading icon keeps rotating forever

I just installed Seatable developer edition on my Ubuntu VPS. Docker is up and running with no errors. The instance is running. I was able to create a base and it also got saved. I can tell it was saved because it was still there when I logged out and logged back in again.

However, when I open it, the loader just keeps rotating and the page never actually loads.

I have mapped port 81 of the host machine to port 80 of the docker container. I have not setup Apache or nginx. I tried accessing it directly using my server IP on port 81. I was able to load and login.

I also tried accessing it using SSH tunneling, but got the same result. Please help with this.
If any other information is needed, please let me know. I’m fairly new to this and this was my first docker based install.

Hi, welcome to the SeaTable Forum! Glad to hear that you are using SeaTable DE.

Have you double-checked your docker-compose.yml?

The SEATABLE_SERVER_HOSTNAME in the docker-compose.yml has a default value of “”. You find this under seatable>environment. Change it to the address of your own site, and it should work. Let me know if this helps!

Hi. Thanks for the response. At first I was trying to access it directly with server IP, without Apache, so it wasn’t working. When I configured it with Apache, I was able to get it to work.

However, I started from scratch again as I had not implemented https the first time. After implementing https, I’m not able to get it to work with Apache server.

This is my Apache config:

   <VirtualHost *:443>
      ServerName *********

  <Location />
    Order allow,deny
    Allow from all
    Require all granted

  ProxyRequests Off
  ProxyPreserveHost On
  ProxyPass /
  ProxyPassReverse /

(The actual file contains my web address in place of *****)

In my docker-compose.yml, I had mapped 444:443 as otherwise the container won’t start. I got it working with this config without https, but it doesn’t work with https. When I try to connect, it says The server encountered an internal error or misconfiguration and was unable to complete your request

How do I configure https with Apache?

Do you follow the instructions in the manual?

There is no need to use Apache. When up-ed, the docker-compose starts a separate nginx container that will receive all requests that come in on port 80 (and 443 when https is configured in the docker-compose.yml).

Sure, you can replace the nginx with Apache, but this is not officially supported. So you will have to figure it out yourself. And because nginx is a part of the SeaTable container, which you cannot leave out, this is not trivial. Hence, why not go with the standard configuration? You can still configure your system to answer to https://YOURDOMAIN:444. Modify the docker-compose and then also the conf files accordingly.

Thanks. I understand now. I am new to this, so I was not able to fully understand what it meant for nginx to be configured in the container.

I’m running it without SSL for now. Will try with SSL later on.

Great. Could you please mark the thread as solved?