Time in Date column not coming through API after upgrade to 3.0.16


I am using the API to populate a date column with “accurate to minute” turned on. Prior to upgrading to 3.0.16, the time would be properly populated. After the upgrade, all times show up as 00:00, as shown:

The string itself coming through the API looks like this:
“2022-06-28T18:00:00.0000000” (without timezone), or:
“2022-06-28T17:00:00+00:00” (with timezone).

I tried both variations (with and without timezone) and I get the same result both ways, all times come through as 00:00. It was working great before the upgrade, hopefully this can be fixed!



Hi Peter, I cannot confirm the problem. I also use the API to write data in a date column. The time info is correct.

Additionally, the upgrade to SeaTable 3.0.16 was done on June 21 (SeaTable 3.0: Datenvalidierung, Office-Webeditoren und neues Speicherbackend - SeaTable). According to your screenshot, the time info was correctly added until June 27.

Hello, sorry, I should have mentioned, I’m on the self-hosted enterprise edition, so the date where the 00:00 starts in my screenshot corresponds to when I performed the upgrade. I made no other changes.

I can manually edit the cell after it has been populated and put in the correct time, but through the API I now can only get the 00:00 no matter what the source is sending.



As I said: We populate multiple bases automatically via API and all the time stamps are correct. So I can rule out be a general problem with SeaTable 3.0.16.

Could you post the api call you use?

@Karlheinz Could you test?

I’m suspicious of the date format you used in your API request. Why do you use such a format? Did you see it in a manual? (If so, please tell us, we’ll correct it :smile: If you are not sure how to format your API call when you append rows, regard to the SeaTable API Reference and go to Base Operations > Rows > Append A Row. There you can see the example of a date format with accuracy to minutes:

I just tested on our cloud (cloud.seatable.io on 3.0.16) platform and our developing test platform (on 3.1.3) and I couldn’t reproduce the problem.


Would you please modify your API request for the date entry and try again? I have sent the API request with the following example request body regarding the date column:

    "table_name": "Table1",
    "row": {
        "Name": "Example row",
        "Date": "2022-07-10 09:44"

Thanks for the follow up, yes I will do some testing and reply back.

I am integrating with Microsoft Outlook, the date and time represents the start of a meeting. The date/time string is exactly as it comes out of the Microsoft API.
I’m not doing any string manipulation before feeding it to the Seatable API, and until now that has worked perfectly.



Found this reference for the date format:

Maybe I’m just lucky that it worked at all, if the applications are using different standards!

I’ll still do some testing but if Seatable isn’t using this format we’ve probably found the answer.


I can confirm that it works fine using the date/time format specified in the Seatable documentation. Since it used to work with the Microsoft/ISO format prior to 3.0.16 I guess I just assumed it was intentional!

Thanks for the help, for now I can figure out my own string manipulation to make it work. You may want to consider using standard formats to maximize compatibility in the future.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.