Update issue on DE

I’m a DE user and was running a 2.5.0.
@rdb pointed me to the new repository on docker hub.
I made the update, but the version info after upgrade (docker down then up) is still 2.5.0 after the image pull.
I’m tried both docker pull seatable/seatable-developer:2.6.0 or docker pull seatable/seatable-developer:latest with the same result.

What am I doing wrong ?

Please follow the upgrade instructions: Upgrade manual - SeaTable Admin Manual

(Hint: Don’t forget updating the database.)

I did that, as usual.
And I did not find any sql upgrade for 2.6 version

I did a fresh install of SeaTable DE 2.5 and upgraded 2.5 to 2.6 following the upgrade instructions. It worked.

Did you modify the image parameter in the docker-compose.yml?

  • Previously: image: seatable/seatable:2.5.0
  • Now: image: seatable/seatable-developer:2.6.0

And, yes, database update is required and a file exists:

1 Like

docker-compose was indeed the issue.
I was still on image: seatable/seatable:latest
switched to image: seatable/seatable-developer:latest
thanks for pointing out !

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.