When grouping by more than 1 level Seatable Freezes when switching to Timeline

Title says it all, I think…
Whenever I group by multiple levels and try to switch to the Timeline plugin, SeaTable freezes and becomes unresponsive.

Only Timeline causes the issue; it doesn’t happen when switching to Kanban or Gallery.

Welcome to the SeaTable forum!

I tried to reproduce your problem on SeaTable Cloud (https://cloud.seatable.io) and couldn’t:

Timeline_plugin

Please specify:

  • Do you encounter these problems on SeaTable Cloud or with your own SeaTable server?
  • Which browser do you use - what does the browser console say?
  • Have you uninstalled and reinstalled the plugin?

Hello!

I tried this both in Firefox and Edge, and the bug was there in both cases.

But I deleted and reinstalled the plugin as suggested and now it works. :slight_smile:
Thanks!

Damn… Solution didn’t last long. :frowning:

I just got the bug again…

Interestingly it disappears when I stop grouping the records in the “Main” view (table).
I’m working on SeaTable Cloud.

Eh… Not sure I can answer this. :o
Unless you give me some instructions. :slight_smile:

I tried again and despite my best efforts, I couldn’t reproduce the problem. So I’d think it’s safe to say: It’s not a general problem but must be somehow related to your base. (By the way, do you encounter the problem only in one base or all your bases?)

As for the browser console, this is what I need:


You can open it with CTRL + SHIFT + I

Hi. The Base I’m using is one of the Template Bases: “Project Tracker”.

I tried another template (“Employee Training”) and there the bug doesn’t seem to appear… Weird.

Here’s a screenshot of the console window:

@rdb Is this what you were looking for?

Hi!

Can you try removing and adding it back?

Proceed as follow (you find all following three commands in the screenshot below):

  • Remove the timelin plugin from the base’s toolbar (using the context menu in the plugin manager)
  • Delete the timeline plugin (using the context menu in the plugin manager)
  • Add the timeline plugin (using the “Add plugins” button in the plugin manager)

Looking forward to hearing from you.

Hi Tim,
could you quickly respond to my comment? Otherwise, I’ll consider this post as solved and close it.

Hi @rdb, issue still persists:

Cheers,
Tim

I should have been more precise: Did you follow my instructions? Can you confirm that the problem persists after re-adding the timeline plugin?

Hi Ralf, yes, I’m a good boy, so of course I followed your instructions first. :slight_smile:

Issue still persists after deleting and re-adding the plugin.

Thanks for being a good kid :wink:

I found the solution: It’s a problem with the template. Your bug can be reliably reproduced in the Project Tracker template. (No wonder I could not reproduce it in any other base.)

When copying all the data from the template into a new base (with everything else being equal), the problem is gone.

We’ll update the template.