🎉 Rework of make.com SeaTable App

I’m thrilled to share that we’ve completed the rework of the make.com app! The updated version offers functionalities similar to the n8n SeaTable Node. While the app isn’t yet available to the public, you can test and use it through the invitation link below:

Invitation Link

I’d greatly appreciate it if you could test it out and share your feedback with me.


Great news - and very surprising after the last status report! In any case, thank you for the quick approach.

At the moment I still get the following message when I try to install via the invitation link:

No modules have been created in the app yet or they have a private status so you cannot add the app to the scenario. Please contact the author of the app or the administrator.
Screenshot 2023-12-29 10.57.40

Greetings, Andreas

Hey Andreas,

Please give it another try. It appears that after “publishing” the app, I needed to make all the modules visible. You should now be able to see these modules:

Happy testing.

1 Like

That worked.

The module is very comprehensive and should - at first glance - satisfy most of the needs of professional make.com/SeaTable users.

What is the plan for releasing the module as an official “v2” within make.com? I currently have a major migration from Airtable to SeaTable that needs to be completed by the end of January 2024. The new module would save a lot of workaround operations…

Greetings, Andreas

Thank you for the initial feedback.

Here’s my plan: I aim to gather feedback in January 2024 and subsequently enhance the app based on that feedback. My goal is to replace the current buggy version with the improved one and make it publicly available in February 2024.

However, I’m uncertain about how things will progress in the following months due to various uncertainties:

  • Will make.com allow the replacement of the existing SeaTable App with the new version?
  • What’s the response time for support from make.com?
  • How positively will the new version be received based on user feedback?

These uncertainties might affect the timeline and process, but I’m committed to navigating these challenges as they arise.

What would you prefer? Why can’t the new version be used? It should be stable by the End of January.

I am delighted to see this and also the option to do a search (including a wildcard search!!), something I have been wanting to have for some time.
Will test the app until you are ready to release.
Thanks to you all

Replacing the old SeaTable app at make.com would destroy all the scenarios that use it so far.

As far as I can tell, the life cycle of the new app has to be adapted successively:


Then all new scenarios can use the new “beta” app and all old scenarios continue to work with the old app - until it is finally transferred to the final “shutdown” state after a certain grace period.

I will test my migration in parallel with the new app and provide feedback. Hopefully we’ll be able to put the app into official beta status soon.

1 Like

So that means that my current scenarios will no longer work after the grace period? Good to know.

Please post both positive and negative experiences with the new make.com app here in the forum. Without feedback, I don’t know if the new app is simply not being used or if everything is working as expected. :slight_smile:

So far, the search rows module works fine but with one unusual thing. Once I set a module and then re-open it to change some settings, the originally selected table needs to be re-selected.
See screenshots

thanks for this hint. I found already the reason for that and I am evaluation how to solve this efficiently.

1 Like

I could resolve the issue: Possible to return an object with an RPC instead of an string? - Custom Apps - Make Community.

By the way:
If you only want to migrate bases from Airtable to SeaTable, you don’t need Make.
There is an Airtable to SeaTable Migration Script that can be executed directly in the python environment of SeaTable. Here is the manual how to do it: Migration from Airtable Bases to SeaTable - SeaTable.

First round of test of the Search Row Module.

I have to activate Case insensitive Search, when searching through a row that contains number, or it’ll return an empty array.

So it technically works, but is an unexpected behavior.

I also found, that only max 100 rows will be returned.

Maybe an option to LIMIT or SORT the results would be cool.

1 Like

Test number 2 Uploading and Downloading a file from Seatable:

1. When a file is uploaded using the upload module. It is then missing the host name (example: https://cloud.seatable.io) in the database. This can be seen when with the get a row module.

The first bundle was uploaded with the make module. The second bundle was upload directly to seatable from my hard drive.

This could lead to trouble, because I would now have to check each url for the hostname, before I can get the download URL through the get the public URL module.

Please add the hostname to Uploaded files from make. :slight_smile:

2 The upload module in make takes all associated files out of that row and replaces them with the uploaded file.
In the upload module, I can tell seatable to overwrite a file if the names are the same. But this does not seem to work properly.

If the names match, the file would be overwritten if the setting is true. If the setting is set to false, a copy is created instead.

At the moment, uploading any file to seatable, just disassociates all the other files from the row. Independent of the Replace setting used. They are still in the base, but not in the row anymore.

Before Upload - 3 files:

After Upload - 1 file:

3. The get public URL module needs a way to set the file name. The returned file name for the PDF uploaded was utf-8. First this was not the original name and more importantly it was missing the .pdf ending.

It is not a breaking bug because I can just change the name later on. But being able to set the file name in the module would be cool.

Thanks for your testings.

  1. Search for a number: I checked, if it is possible to make it possible to search for numbers without activating “Case Insensitive Search”. This would require that make could detect what kind of input was provided. Unfortunately, this only works with a custom IML function, which I would like to avoid. Therefore I added a hint to prevent this situation.

  2. Only 100 returns
    I cannot see why this returns only max. 100 rows. The API endpoint I use, return up to 1.000 rows. BUT I think results of more than 100 rows are in general a problem with make and should be avoided. Also there is a much better solution with Get rows where you can select a view and bind the logic to the view instead of creating the logic in the Search module in make.

1 Like

I already fixed this.

1 Like

I fixed this by adding another parameter:

1 Like

I don’t get your point. My module “Get the public URL from Asset Path” module looks totally different:

I fixed this by adding another parameter:

Thanks! Keeping the files is working for files uploaded through make. If I add a file to the row in seatable, it will be dissaccociated. :frowning_face: :