SeaTable 3.5 out now!

SeaTable 3.5 is now available! We have updated SeaTable Cloud this morning at 6 am CET. The Docker image of SeaTable Server 3.5 can also be downloaded from Docker Hub.

Here just the biggest highlights of the new release. You find a more detailed description of SeaTable 3.5 in the Release Notes. We documented all changes – as always – in the Changelog.

  • Formulas in column 1: Leverage the power of formulas any column you want– yes, including the first column.

  • More periodic automations: Run all data processing operations automatically based on your schedule.

  • Conditional button actions: Define your own rule set as to when a button action is executed and when it is not.

  • Conditional lookups: Fine-tune your link formula column and lookup exactly the data you need.

  • Improved design: Enjoy a two-column layout in the rows details and a base log that has been freed from the confines of the side panel.

SeaTable 3.5 implements a character limit for long text columns. A long text cell containing text longer than 100.000 characters (roughly 25 DIN A4 pages) will only save the first 100.000 characters.

Another important change for users of SeaTable Cloud’s API: With this update, we have reduced the maximum number of rows returned in a single API call. In the past, a maximum of 10.000 rows were returned. Now, a response contains a maximum of 1.000 rows. Please check if this requires adjustments in your integrations.


This update also improved the overall response time by a lot. :slight_smile: :+1:


Here is also a YouTube video with an introduction to the new features (the video is in German).


Amazing update with many very useful features :clap: I have one problem/question though, when I open the apps window to add an app I only get the options Gallery and Data Query but not the Universal App. That is on 3.5 self-hosted Enterprise Edition. Am I missing something or is the Universal App only available for cloud users at this time?

1 Like

Add the following to the We will add this to the admin manually shortly, too.


I thought about asking the same question :smiley:

Hi @cdb.

First things first: I love the UAB!

I know the Universal App Builder is still Beta, but I already have some things for you:
Translated my german notes via google translate for the other users.

  • Topic 1:
    • A sharing link was created
    • Permission set: Unrestricted access → Allow unregistered users
    • Edited: Users without an account cannot change data in the table (intended?). Also buttons cannot be pressed from unknown users.
    • Added: It would be awesome when the admin can decide which field can be edited by an unknown user.
  • Topic 2:
    • Add a new page (table)
    • Adding a new column as a base owner
    • The new column is not displayed in the table on the page
    • The new column will appear when creating a second page (table).
    • If you delete the column, it will be removed from the second page
      - Edit: Just found out newly added columns are just hidden. You have to manually make them visible
  • Topic 3:
    • Custom page changes do not affect for unlogged users (similar to issue 2)
    • Workaround (also for problem 2):
      • Remove and reassign the permission for “Allow unregistered users”. Then the changes are applied.


  • Thema 1:
    • Es wurde ein Freigabelink erstellt
    • Berechtigung gesetzt: Uneingeschränkter Zugriff → Unangemeldete Benutzer erlauben
    • Edit: Benutzer ohne Konto, können keine Daten in der Tabelle ändern (gewollt?). Auch Schaltflächen können nicht gedrückt werden.
    • Added: Hier wäre es nett, wenn der Admin entscheiden könnte, welche Spalten bearbeitet werden dürfen und welche nicht.
  • Thema 2:
    • Hinzufügen einer neuen Seite (Tabelle)
    • Hinzufügen einer neuen Spalte als Base-Inhaber
    • Die neue Spalte wird nicht in der Tabelle auf der Seite angezeigt
    • Die neue Spalte wird beim Erstellen einer zweiten Seite (Tabelle) angezeigt
    • Wenn man die Spalte löscht, wird sie aus der zweiten Seite entfernt
      - Edit: Gerade gesehen, dass neu hinzugefügte Spalten als ausgeblendet angezeigt werden. Man muss sie manuell sichtbar machen
  • Thema 3:
    • Änderungen an der Individuellen Seite wirken sich nicht auf für unangemeldete Benutzer aus (ähnliches wie Problem 2)
    • Workaround (auch für Problem 2):
      • Die Freigabe für „Unangemeldete Benutzer erlauben“ entfernen und neu vergeben. Dann werden die Änderungen übernommen.

Thanks for your feedback. Please allow us some time to check the points and send us more feedback if you have more.

1 Like

Here are some more :slight_smile:

  • Topic 4:
    - You cannot delete the last existing navigation element
  • Topic 5:
    • Edit: not relevant
  • Topic 6:
    • A column is hidden in the table overview
    • The column is no longer displayed
    • The column is displayed again via the menu on the right. After the automatic update, only the column that is shown again is displayed, the other columns are no longer displayed.
    • The web page is updated with F5
    • The column view is displayed as desired
  • Added: Topic 7:
    • The default value “0” is not being accepted in text fields and being resetted after deselecting and selecting again


  • Thema 4:
    • Das letzte vorhandene Navigationselement kann man nicht löschen
  • Thema 5:
    • Edit: Irrelevant
  • Thema 6:
    • Eine Spalte wird in der Tabellenübersicht ausgeblendet
    • Die Spalte wird nicht mehr angezeigt
    • Die Spalte wird über das Menü rechts wieder eingeblendet. Nach der automatischen Aktualisierung wird nur noch die wieder eingeblendete Spalte angezeigt, die anderen Spalten nicht mehr.
    • Die Webseite wird mit F5 aktualisiert
    • Die Spaltenansicht wird wie gewünscht dargestellt
  • Added: Thema 7:
    • Der Standardwert “0” wird in Textfeldern nicht akzeptiert und auf leer zurückgesetzt nach dem Neuselektieren

I cannot reproduce the issue.

What I did: I have two items in the navigation. I click on the three-dot-icon of the last item and select “Delete page”. The disappears.

Good one!

I cannot reproduce the issue. I can set the default value, leave the page and return to the page, the default value is still where and what it is supposed to be (see below).

Topic 4:

I cannot remove the last remaining item (The data type is number):

Topic 7:

And here it is not possible to set 0 as default value. When I unselect “Wasser” and klick on it again, the default value is gone:

Hi, thanks the updates!

Currently we are having a problem with forms, when choosing a link record column in a form it doesnt find the last records in the table linked. This problem started yesterday.


I think I might have a solution for you there because I had the same problem. It seems the last update has changed the URL of forms. Once I took the “new” one it was able to find all records again.

On a side note, I also had to re-insert most static image elements in Page Designer after the update as they somehow got lost.

I second this. It would be really useful to be able to send the link to anonymous users and allow them to modify records. I could also not make this work even with open access enabled.

1 Like

I couldn’t agree more! I hope Seatable can allow anonymous users to edit specific rows/columns, as this would be very helpful when allowing people outside the organization to input data or run scripts

Another thing I am thinking of is, is there a way in the UAB to “identify” an unknown user?

For example an unknown user could be able to define his own settings. These settings would be stored as a cookie or in the browser based storage for example with the option to export these settings and import it on another computer again.
What I mean is at the moment I have to create one app for each user and redo any setting for each new app over and over again like groupings or filters.

Another approach would be to be able to copy UABs. In that case I would only have to set user based filters or so.

It happens to me as well.



Probably some restriction has been applied to not allow an application to have no pages or folders.


I’m still exploring all the included features in the update but overall it’s awesome!

Thank you and congratulations on all the team job!

Thanks for confirming @dcbn. They did indeed a very good job.

Found a visual style issue. There are two scroll bars appearing in the table page.

When I scroll the table (cursor is on the table) both scrollbars are moving. When I move the cursor between the two scroll bars I cannot scroll the table. It seems like the options panel is somehow interfering. I have some hidden columns on that table page.

I also found out the validation of text columns do not apply. When I enter some text via the form page the validation does not work. Maybe the dev team didn’t develop it yet? :slight_smile:

Column definition in the base table:

Field definition in UAB form page:

Validation in base table column:

No validation in UAB form page text box:

Thanks! i have created a new form and still the same problem, can you share what was previous url and whats now or how do I get the “new” one?

Thangas again for your help

In your form editor, when you create or edit a form you get a form URL. That is the one I was talking about. You just have to go in there again and copy/use the one in there instead of the one used before. At least that worked for me.